po aktualizaci chyba - zmizel instalátor

Velitel
26. úno 2017 10:58 #130335
Ahoj mám prosbu.
Po aktualizaci na ver.zi 3.6.5 píše

Nebyl povolen žádný instalační plugin. Alespoň jeden musí být povolen, aby bylo možné použít instalační program. Přejděte na Plugin Manager a povolte pluginy.

přitom jsou pluginy povoleny.
Dále pak po upgrade vyhodil chybu:

Upozornění
JInstaller: :Instalace: Chyba SQL Duplicate entry '453' for key 'PRIMARY' SQL=INSERT INTO `#__extensions` (`extension_id`, `name`, `type`, `element`, `folder`, `client_id`, `enabled`, `access`, `protected`, `manifest_cache`, `params`, `custom_data`, `system_data`, `checked_out`, `checked_out_time`, `ordering`, `state`) VALUES (453, 'plg_editors-xtd_module', 'plugin', 'module', 'editors-xtd', 0, 1, 1, 0, '', '', '', '', 0, '0000-00-00 00:00:00', 0, 0);
Aktualizace souborů: chyba SQL souboru DB funkce selhala, číslo chyby 1062
Duplicate entry '453' for key 'PRIMARY' SQL=INSERT INTO `#__extensions` (`extension_id`, `name`, `type`, `element`, `folder`, `client_id`, `enabled`, `access`, `protected`, `manifest_cache`, `params`, `custom_data`, `system_data`, `checked_out`, `checked_out_time`, `ordering`, `state`) VALUES (453, 'plg_editors-xtd_module', 'plugin', 'module', 'editors-xtd', 0, 1, 1, 0, '', '', '', '', 0, '0000-00-00 00:00:00', 0, 0);
SQL =

INSERT INTO `#__extensions` (`extension_id`, `name`, `type`, `element`, `folder`, `client_id`, `enabled`, `access`, `protected`, `manifest_cache`, `params`, `custom_data`, `system_data`, `checked_out`, `checked_out_time`, `ordering`, `state`) VALUES
(453, 'plg_editors-xtd_module', 'plugin', 'module', 'editors-xtd', 0, 1, 1, 0, '', '', '', '', 0, '0000-00-00 00:00:00', 0, 0);

Prosím o radu co s tím. Díky

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
26. úno 2017 19:10 #130343
Povolte si plugin Instalátor - instalace z URL. Nebo proveďte instalaci plného posledního balíčku, který si nejprve stáhnete do PC. Na závadu určitě nebude napřed opravit tabulky databáze v Rozšíření: Databáze a v phpMyAdmin.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Velitel
27. úno 2017 18:29 #130352
provedena instalace celého balíčku, opraveny tabulky databáze a v phpMyAdmin,nicméně stále píše:

Upozornění
Nebyl povolen žádný instalační plugin. Alespoň jeden musí být povolen, aby bylo možné použít instalační program. Přejděte na Plugin Manager a povolte pluginy.

Když vlezu do manageru tak žádný plugin typu Instalátor - instalace z URL nemohu najít a to ani v povolených ani v zakázaných.
Prostě chybí :woohoo:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
27. úno 2017 20:23 - 01. bře 2017 17:04 #130355
Jak jak se vám může povést instalace celého balíčku, když nemáte žádný instalační plugin?

Hledejte všechny pluginy typu installer. Ve vaší Joomle se nacházejí pluginy:
  • Instalátor - instalace z místního počítače
  • Instalační program - instalace ze složky
  • Instalátor - instalace z URL

Zkuste funkci Rozšíření: Pátrání, která vám "ztracená" rozšíření může znova nainstalovat pokud existují alespoň potřebné soubory... V databázi by pak mělo být asi toto:
--
-- Vypisuji data pro tabulku `xxx_extensions`
--

INSERT INTO `xxx_extensions` (`extension_id`, `name`, `type`, `element`, `folder`, `client_id`, `enabled`, `access`, `protected`, `manifest_cache`, `params`, `custom_data`, `system_data`, `checked_out`, `checked_out_time`, `ordering`, `state`) VALUES
(455, 'plg_installer_packageinstaller', 'plugin', 'packageinstaller', 'installer', 0, 1, 1, 1, '{"name":"plg_installer_packageinstaller","type":"plugin","creationDate":"May 2016","author":"Joomla! Project","copyright":"Copyright (C) 2005 - 2016 Open Source Matters. All rights reserved.","authorEmail":"admin@joomla.org","authorUrl":"www.joomla.org","version":"3.6.0","description":"PLG_INSTALLER_PACKAGEINSTALLER_PLUGIN_XML_DESCRIPTION","group":"","filename":"packageinstaller"}', '', '', '', 0, '0000-00-00 00:00:00', 1, 0),
(456, 'PLG_INSTALLER_FOLDERINSTALLER', 'plugin', 'folderinstaller', 'installer', 0, 1, 1, 1, '{"name":"PLG_INSTALLER_FOLDERINSTALLER","type":"plugin","creationDate":"May 2016","author":"Joomla! Project","copyright":"Copyright (C) 2005 - 2016 Open Source Matters. All rights reserved.","authorEmail":"admin@joomla.org","authorUrl":"www.joomla.org","version":"3.6.0","description":"PLG_INSTALLER_FOLDERINSTALLER_PLUGIN_XML_DESCRIPTION","group":"","filename":"folderinstaller"}', '', '', '', 0, '0000-00-00 00:00:00', 2, 0),
(457, 'PLG_INSTALLER_URLINSTALLER', 'plugin', 'urlinstaller', 'installer', 0, 1, 1, 1, '{"name":"PLG_INSTALLER_URLINSTALLER","type":"plugin","creationDate":"May 2016","author":"Joomla! Project","copyright":"Copyright (C) 2005 - 2016 Open Source Matters. All rights reserved.","authorEmail":"admin@joomla.org","authorUrl":"www.joomla.org","version":"3.6.0","description":"PLG_INSTALLER_URLINSTALLER_PLUGIN_XML_DESCRIPTION","group":"","filename":"urlinstaller"}', '', '', '', 0, '0000-00-00 00:00:00', 3, 0);

I'm sorry, my responses are limited...you must ask the right questions.
Poděkovali: Velitel

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Velitel
27. úno 2017 20:37 #130357
Ani jeden plugin typu installer jsem nenašel, nakonec pomohlo "pátrání", našlo to 6 pluginů včetně všech tří instalátorů, instalace úspěšná. Díky moc.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.