nelze se přihlásit do Administrace

ZAJDAN
04. říj 2016 17:49 #128604
Ahoj,
náhle se mi objevil problém a nemohu se přihlásit do administrace webu.
192.168.1.1/administrator
naběhne přihlašovací stránka
zadám jmeno, heslo a stranka jakoby se refreshuje a nedojde k přihlášení


díky

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
04. říj 2016 18:14 #128606
192.168.1.1 je vnitřní adresa sítě, určitě ne veřejná. Vypadá to dokonce na adresu brány.
Pokud to máte nainstalováno na lokále musí Vám tam běžet virtuální webový server (xampp, vertrigo atd) a adresa pak bude localhost /administrator

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od ZAJDAN
04. říj 2016 18:17 - 04. říj 2016 18:19 #128607
ta adresa je jen pro demonstraci...tu ted nereste..podstatne je ze logovaci stranka administrace nabehne
mam takove podezdreni, ze by to mohlo delat zaple SSL v apachi, ktere mam zapnute kvuli jinemu webu na kterem bezi certifikat

ted jsem web i s databazi nasadil na jinem stroji s apachem kde SSL nebezi a prihlasim se v poradku

je tedy mozne, ze pricinou bude SSL mod v apachi?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
04. říj 2016 18:28 #128610
tak neblbněte lidi a dejte sem skutečnou adresu
až ji uvidím, mohu najít příčinu

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od ZAJDAN
04. říj 2016 18:29 #128611

ernst napsal: tak neblbněte lidi a dejte sem skutečnou adresu
až ji uvidím, mohu najít příčinu


komu ta lokalni adresa pomuze, kdyz to bezi na lokalnim serveru, vzdyt to s problemem nesouvisi

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
04. říj 2016 18:38 - 04. říj 2016 18:42 #128612
to je konečně informace, že to běží na lokálním serveru.
Pod jakým SW?

a s problémem to setsakramentsky souvisí.
Zkontroloval jste si v developer toolu (či obdobném) consoli logy a další věci?

a na localhostu se spoustu věcí chová úplně jinak než na webu, třeba zrovny to SSL

hodte si web třeba na endoru a uvidíte

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od ZAJDAN
04. říj 2016 18:40 #128613

ernst napsal: to je konečně informace, že to běží na lokálním serveru.
Pod jakým SW?


Debian 8
Apache/2.4.10 (Debian)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
04. říj 2016 19:02 #128614
- Nová instalace nebo stávající?
- Dřív přihlášení fungovalo?
- Co jste měnil?
- Nedeaktivoval jste nepotřebné pluginy?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
04. říj 2016 19:03 - 04. říj 2016 19:04 #128615
takže je to jen webový server, na který se nelze dostat zvenčí.
nakopírujte si web na endoru (hosting zdarna) www.endora.cz a tam se na to můžem podívat
záloha a obnovení akebou Vám zabere tak 30 minut

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od ZAJDAN
04. říj 2016 19:13 #128616
hosi diky, ale to neni joomlou jako takovou...
joomle se jen proste prestalo neco libit na serveru a ja vazne podezdrivam SSL na apachi, keter tam puvodne nebylo
web jsem zkusil prenes na jiny stroj s bezicim apachem bez SSL - vse v poradku

otazka je...jak nastavit joomlu/apache aby se to nepralo s SSL(ktere se pouziva pro jiny web)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od ZAJDAN
04. říj 2016 19:53 - 04. říj 2016 19:56 #128618
SOLVED:
a2disconf content-security-policy.conf

kde obsahem je:

<IfModule mod_headers.c>

        Header set   Content-Security-Policy   " script-src 'self' https://code.jquery.com https://ajax.googleapis.com http://maps.googleapis.com 'unsafe-inline' 'unsafe-eval' ; font-src  'self' https://fonts.googleapis.com https:$
        Header set X-Content-Security-Policy   " script-src 'self' https://code.jquery.com https://ajax.googleapis.com http://maps.googleapis.com 'unsafe-inline' 'unsafe-eval' ; font-src  'self' https://fonts.googleapis.com https:$

        Header edit Set-Cookie ^(.*)$ $1;HttpOnly;Secure

        Header unset X-WebKit-CSP
        Header add X-WebKit-CSP "default-src 'self'"

        Header set X-Content-Type-Options "nosniff"
        Header set X-XSS-Protection "1; mode=block"
        Header set X-Frame-Options "SAMEORIGIN"
        Header set Strict-Transport-Security "max-age=63072000; includeSubDomains"

 </IfModule>

toto jsem nasazoval spolešne s SSL

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.