Přihlásit se

Upozornění!

05. úno 2013 18:54 - 05. úno 2013 19:27 #103543
Upozornění! vytvořeno Bart
Joomla verze: 3.0.x, 3.1.x a 3.2.x je určena pro zkušenější uživatele, nadšence a především pro vývojáře.
Slouží vlastně k otestování funkčnosti nově zaváděných funkcí, které pokud se osvědčí, se objeví ve verzi s dlouhodobou podporou. Aktuální verze s dlouhodobou podporou je Joomla 2.5.x, následující verze s dlouhodobou podporou je Joomla 3.5.x

Ve verzích s krátkodobou podporou jsou zavedeny funkce, které nejsou plně otestovány na všech konfiguracích a parametrech, mohou v průběhu vydávání zmizet (což by byl v LTS verzi problém), samotný systém také většinou není moc rozšířený mezi uživateli, takže je možné, že se bude řešení problému hledat hůře, většinou není ani mnoho dostupných rozšíření pro tyto verze - mnoho vývojářů tuto verzi ignoruje a zaměřuje se na verze s dlouhodobou podporou. Vývojáři na bezpečnostní verze tolik nespěchají. Důvod je jasný, tyto verze slouží k testování.

Joomla 3.0 není tak úchvatná :), aby musela být nutně nasazena. 99,9% funkcí a možností Joomly 3.0, obsahuje Joomla 2.5.x také, přesněji od verze 2.5.7.

Verze s dlouhodobou podporou (LTS - long term support), jinak řečeno hlavní verze, mají minimální dobu podpory (tj. např. vydávání bezpečnostních balíčku, rozšíření a dalších..) 2 roky.
Tyto verze jsou označeny ve formátu x.y, kde x je číslo další verze (1,2,3,... - vždy celá čísla) a y je vždy číslo 5, které značí právě LTS verzi.

Verze s krátkodobou podporou (STS - short term support), jinak řečeno vedlejší verze, mají dobu podpory 6 měsíců.
Tyto verze jsou označeny ve formátu x.y, kde x je číslo další verze (1,2,3,... - vždy celá čísla) a y může nabývat hodnot: 0, 1, 2. Tyto čísla (y) označují verze s krátkodobou podporou.

Nikdo Vás nenutí nenasazovat STS verze, je to Váš problém jestli ji nasadíte. Toto je pouze doporučení proč STS verze nenasazovat.
U nově zaváděných verzí můžete vždy počítat s nějakou neočekávanou chybou, tak to je. A především u Joomla s STS, která není dlouho podporována.
.
Joomla 2.5.x je v této době velmi stabilní a velmi dobře funkční. Podařilo se najít a opravit mnoho problémů. Jedná se zatím o nejlepší verzi Joomly.

Plánovaný harmonogram vydávání verzí:
Verze 2.5: březen 2012 (LTS verze)
Verze 3.0: září 2012
Verze 3.1: březen 2013
Verze 3.2: září 2013
Verze 3.5: březen 2014 (LTS verze)
Verze 4.0: září 2014
Verze 4.1: březen 2015
Verze 4.2: září 2015
Verze 4.5: březen 2016 (LTS verze)

14. úno 2013 15:24 - 14. úno 2013 15:25 #104016
Odpověď od karel
Mě tak napadá ... proč to nehodit do normálního článků? Fórum si "Běžní Tazatelé" nepoužívají jako zdroj obecných informací.

Znáte-li řešení, sdělte ho - pomůžete ostatním při řešení stejného problému, i případný "rádce" bude vědět, poradil-li správně nebo špatně.

14. úno 2013 21:47 #104021
Odpověď od Bart
Bohužel, běžní tazatelé neřešení články nebo forum. Do fora si jdou pouze pro radu. Tím to hasne. Kdyby jsi tady měl milion článků, pokrývajících 99,9% problémů a možností v Joomle, stejně vše bude při starém. Přitom forum na JoomlaPortale je stěžejní zdroj informací o Joomle v češtině. Články na JoomlaPortalu beru jako nepatřičný přidanou hodnotu / bonus (on je totiž stejně nikdo nechce psát :(). Navíc málokdo je čte.

17. dub 2013 09:26 #106710
Odpověď od domorodec
Dobrý článek. Díky.

Domorodec

13. čvc 2013 21:19 #109273
Odpověď od Jan Vydra
ahoj, v joomle jsem absolutní elév... a po přečtení bártova upozornění to vidím takhle - když jsem si nainstaloval trojku a snažil se přes tutoriál na youtube jako vopice napodobovat, co sem viděl na obrazovce, asi to nebyl nejlepší nápad... výsledkem je těžkej bolehlav z dvoudenní snahy a vztekání se, že kamarád, co mi řekl, že v joomle by udělala z fleku stránky moje máma, je pěknej vůl...

prosím tedy o radu - nainstalovat verzi 2.5 a zkoušet??? nebo zainvestovat do školení???

děkuji moc za každou odpověď

vydrouš

13. čvc 2013 21:49 #109274
Odpověď od Karri
Každý začátek je těžký :-) Pokud jste začátečník a chcete stránky do budoucna provozovat na Joomla!, doporučuji se rovnou učit na 3.1 . Joomla! 2.5 bych doporučil těm, co chtějí ihned spustit stránky a s Joomla umí pracovat.
Mezi námi, 3.1 je mnohem zajímavější a pokročilejší, než 2.5 :-)

Powered by Fórum