Joomla! 3.7

Teo
25. dub 2017 21:24 #131129
Ahoj všichni. Dnes byla oficiálně uvolněna nová verze Joomla! 3.7. Má už někdo nějaké čerstvé zkušenosti či poznatky s aktualizacemi?
Mimochodem by to možná chtělo změnit název diskuzního vlákna (je tam jen 3,0 až 3.6) ;-)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
25. dub 2017 22:46 #131130
Jedna instalace už mi na 3.7 běží, ale začínal jsem s ní na 3.7RC, zatím vše v pohodě.
3.7 nicméně opravuje 8 bezpečnostních děr (sice s nízkou prioritou, ale přece), s aktualizací bych tedy až tak dlouho neotálel.
viz. developer.joomla.org/security-centre.html

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Teo
25. dub 2017 23:11 - 25. dub 2017 23:13 #131131
Tak už jsem aktualizoval asi 5 webů, které "jely" na 3.6.5 a úplně bez problémů. Jen u těch, kde to běží na PHP verze nižší než je 7.0 tak to hlásí informaci, něco ve smyslu doporučujeme... Jednalo se o webhostingy Wedos a Savana.
Jinak nevím, jestli to tu někde na fóru zaznělo, ale pokud přejdete na verzi PHP 7, tak se celkově většina CMS systémů zrychlí. A to nejen Joomly, ale např. i Moodle. Tam je to teda dost markantní. Aspoň co já mám zkušenost.
Jo ještě jsem si vzpomněl, že v nové verzi 3.7 samozřejmě přibylo v administraci pár věcí, tak že dokud nebude hotov překlad, tak tam figurují anglicky. Ale to je jen otázkou času, kdy si kluci, co dělají překlady na to udělají čas. Na samotný chod to nemá žádný vliv. Ale to je asi jasné ;)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
25. dub 2017 23:13 #131132
Mám 3.7 již na 3 webech. Zatím jsem na problémy nenarazil.
Jen se mi zdá, že zatím chybí nějaké překlady v češtině a objevila se hláška s doporučením na přechod na PHP 7.

Mimochodem, nevíte jestli J1.5 PHP7 stráví?

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od H13
26. dub 2017 00:47 #131133

Mimochodem, nevíte jestli J1.5 PHP7 stráví?


Nedostaneš se ani k instalaci:
Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in... includes\framework.php:21 Stack trace: #0 ... index.php(22): require_once() #1 {main} thrown in ... includes\framework.php on line 21

Phoca Gallery - http://www.phoca.cz/phocagallery - obrázková galerie (Joomla!)
Phoca Guestbook - http://www.phoca.cz/phocaguestbook - kniha návštěv (Joomla!)
Phoca Download - http://www.phoca.cz/phocadownload - stahování souborů (Joomla!)
Phoca Cart - http://www.phoca.cz/phocacart - e-shop,...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Teo
26. dub 2017 00:48 #131134
U starších verzí mám zkušenost, že některé komponenty či pluginy nebo moduly hlásí chybové hlášky. Většinou stačí vypnout všechny chybovky v nastavení Joomly a jede to dál. Mám ale jeden web na 2.5, který v administraci po přechodu na PHP vyšší verze stejně hází chybovou hlášku, ale je to jen v administraci.
Jestli ale vezme ještě stará verze 1.5 PHP 7, to netuším. Už ji nikde nemám.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Teo
26. dub 2017 00:49 - 26. dub 2017 00:52 #131135
On měl Bong Honzo asi na mysli, pokud už ji někde máš nainstalovanou a přejdeš na vyšší verzi PHP v nastavení webhostingu.
Ještě doplním, že jsem takto zkoušel několikrát přepnout "na zkoušku" třeba na Wedosu vyšší verzi PHP a když to nejede, tak se zase "přepnu" zpět. Otázka max. 15 minut.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
26. dub 2017 01:08 - 26. dub 2017 01:08 #131136

Teofil napsal: Jen u těch, kde to běží na PHP verze nižší než je 7.0 tak to hlásí informaci, něco ve smyslu doporučujeme...

Lze vypnout - plugin "Quick Icon - PHP Version Check"
Nevím jak wedos, ale Savana už PHP 7 má (lze přepnout v administraci), jen pozor, pokud tam máte ještě někde oomlu 2.5, ta na PHP 7 nefunguje.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
26. dub 2017 01:09 #131137

Bong napsal: Mimochodem, nevíte jestli J1.5 PHP7 stráví?

Ne, ani 2.5 to nestráví...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jiří
26. dub 2017 07:55 #131138
na forpsi i na active24se po aktualizaci divně rozjela grafika, musel jsem u active24 jít na obnovu zálohy.Forpsi jako nejdražší zatím na mé výtky neraguje
Ještě jedna věc? (typeError: Cannot read property 'replace' of undefined:Nelze přečíst nahrazení nedefinované vlastnosti: u článků editor JCE)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Teo
26. dub 2017 08:31 #131139
Tak už jsem narazil na první komponenty, které nefungují s novou verzí - DP Calendar a Visfoms (ti to mají i na svých stránkách napsané).

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
26. dub 2017 21:38 #131151

humpolikJ napsal: Forpsi jako nejdražší zatím na mé výtky neraguje

B)

humpolikJ napsal: Ještě jedna věc? (typeError: Cannot read property 'replace' of undefined:Nelze přečíst nahrazení nedefinované vlastnosti: u článků editor JCE)

JCE PRO 2.6.11 mi to nic takového nehlásí. Je to opravdu z JCE? Ještě by to mohl být nějaký Editor button...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od ferino
27. dub 2017 12:24 - 27. dub 2017 12:25 #131164
Tak pripojím moju malú skúsenosť s upgrade na J37:
väčšina webov bez problémov zvládla tento upgrade, a to boli rôzne verzie PHP (aj staré)
ale na jednom to skončilo takto, viď príloha.
Pritom upgrade skončil akože OK, bez akejkoľvek chyby, aj web v podstate beží, iba tie stringy chýbajú, v admin rozhraní mám English default, a keď sa pozriem na súbory do language foldra, vyzerá, že tam všetky sú, napriek tomu sa nezobrazujú.
Nechápem...
Přílohy:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
27. dub 2017 21:04 #131170
A po zapnutí ladění chyb jazyku v globální konfiguraci to hlásí co?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
27. dub 2017 23:16 #131176
Možná to s tím souvisí, možná ne (ale pro Bonga by to mohla být podstatná informace).

Joomla 3.7 již neumí pracovat s jazykovými soubory, které v překladech používají sekvenci "_QQ_" pro dvojité uvozovky. Tento způsob byl označen za zastaralý (deprecated) a není již nadále podporován.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.