Přihlásit se

Joomla 5.0.3 a 4.4.3 bezpečnostní aktualizace (02 dub 2024)

Joomla 5.0.3 a 4.4.3 je nyní k dispozici. Jedná se o bezpečnostní vydání pro Joomla 4.x. a 5.x.

Stabilita API Joomla

07. bře 2024 12:43 #149250
Stabilita API Joomla od jomlista
Uživatel
Nevíte někdo jak je to se stabilitou API Joomla 5, tedy jestli se někde neřeší jestli by v Joomla 6 bylo zase MVC nějak překopané. Přemýšlím totiž jestli jet se starými rozšířeními prozatím v legacy módu a počkat na Joomlu 6 jestli to tam nebude nějaké překopané.

07. bře 2024 13:04 #149251
Odpověď od Cony
Moderátor
Nový rozšíření, kde nepotřebuji podporu J3 už píšu v novém API. Mezi J4 - J5 tam nebyl myslím žádný, nebo minimální rozdíl, v J6 by měl primárně ubýt legacy plugin, ale v rámci framework by změny být neměli.
Stará rozšíření zatím nechávám v legacy MVC (i když hlavně z důvodu podpory J3), i tak se dají upravit aby fungovala v J5 bez legacy pluginu (je to v podstatě jen o důsledně používaných namespace, jen při paralelní podpoře J3 je potřeba pro J3 některé třídy aliasovat). Např. u komponent lze i zkombinovat (viz např. PhocaCart 5), kdy se používá legacy MVC ale zároveň i Dispatcher (viz třída Joomla\CMS\Extension\LegacyComponent).

01. dub 2024 15:27 #149314
Odpověď od jomlista
Uživatel
Je k tomu někde více info, jak psát kompatibilní komponenty?

Předem děkuiji.

03. dub 2024 12:51 #149324
Odpověď od Cony
Moderátor

05. dub 2024 21:17 #149340
Odpověď od Rudolf
Joomla Expert

MiniJoomla! - www.minijoomla.org - eshop s rozšířením Joomla/VM
Email Manager - aplikace na správu šablon emailů pro VirtueMart
Easy Feeder - aplikace na generování XML/CSV feedů a napojení na ERP pro VM
PragueClassicconcert - portál pro prodej vstupenek na systému Joomla

Powered by Fórum