Migrace z J2.5.26

vlada
15. led 2021 15:58 #143549
Hezký den
Zkoušel někdo poslední dobou migrovat z J2.5.26 na J3.x? Komponenta Aktualiza Joomly mi neustále hlásí
"Nemůžeme nainstalovat aktualizaci 3.5.1, protože hosting nepodporuje minimální požadavky pro Joomla 3.5.1 a není k dispozici žádná alternativa. "
Zkouším to na WAMP2.5, WAMP3.2, XAMP3.2.3 a pořád nic ačkoli by všichni měli splňovat minimální podmínky pro běh obou verzí Joomla.
Máte někdo nápad jak přemigrovat jínak nebo kde by mohla být chyba?
Díky Vlada

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Rudolf
15. led 2021 17:30 #143550
Nápadů je spousty, třeba ten co jsem už minule psal.
Tento týden jsem převedl za 4 hodiny 4 weby. bez wampu, xampu či jiného ampu...

Ale je pravda, že mám k dispozici asi 15 firemních serverů a local používám jen na mergování gitu - to se mi to radí co? :D
(i když ten MAMP Pro taky někdy spustím).

MiniJoomla! - www.minijoomla.org - eshop s rozšířením Joomla/VM
Email Manager - aplikace na správu šablon emailů pro VirtueMart
Easy Feeder - aplikace na generování XML/CSV feedů a napojení na ERP pro VM
PragueClassicconcert - portál pro prodej vstupenek na systému Joomla

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od vlada
15. led 2021 17:48 #143551
No jo, dokud vše funguje, tak je hej. Peklo začne, až když to nefunguje, jak má. A to jsem WAMPu tak věřil :-((. Vlastně i Joomle :-((

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Rudolf
15. led 2021 18:05 #143552
Ty ampy jsou jen náhražka.

Mnohokrát jsem to vysvětloval programátorům, že to není 100% spolehlivé.
Kolegyně kodérka používala a pak nefungovaly cesty k lokálním souborům v gitu == její změny z lokalu se velmi obtížně propisovaly a nasazovaly na hosting.

Přece jako programátor / admin musíte vědět, že nejsprávnější metoda je mít vývoj webu přímo na hostingu se stejnými parametry jako pak bude produkce a při použití Jmigrátoru dnes už ani nemusíte mít původní web na stejném serveru.
Pak Vás nic nevyděsí a poznámky o Joomle budou mimo mísu.

Držím pěsti aby to odsýpalo

MiniJoomla! - www.minijoomla.org - eshop s rozšířením Joomla/VM
Email Manager - aplikace na správu šablon emailů pro VirtueMart
Easy Feeder - aplikace na generování XML/CSV feedů a napojení na ERP pro VM
PragueClassicconcert - portál pro prodej vstupenek na systému Joomla

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Rudolf
15. led 2021 18:50 - 15. led 2021 18:52 #143553
Ještě si vzpomínám, že kdysi, ještě než jsem používal JMigrátor, jsem měl vytvořený postup upgradu na Joomla 3.2.
Tak jsem byl schopen dělat migraci na serveru s PHP54 nebo PHP56, podle toho, na jakém PHP běžela stará J25.

Následný upgrade jsem přesunul na vyšší PHP56, kde už upgrade J3.2 na vyšší verzi prošel.

Bylo to tedy trochu zdlouhavé...

MiniJoomla! - www.minijoomla.org - eshop s rozšířením Joomla/VM
Email Manager - aplikace na správu šablon emailů pro VirtueMart
Easy Feeder - aplikace na generování XML/CSV feedů a napojení na ERP pro VM
PragueClassicconcert - portál pro prodej vstupenek na systému Joomla

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od vlada
15. led 2021 19:07 #143554
Jo, já si taky vzpomínám, že jsem před 10 lety uměl komponentu Attachments přinutit, aby ukládala přílohy do jiného, než defaultního adresáře :-)
No nic, poslední půlrok je mým heslem Co tě nezabije, to tě posílí. Mám volný jeden hosting včetně domény, tak na něm odzkouším, jestli bude fungovat automatická aktualizace Joomla.
Je to přesně to, co jsem dělat nechtěl, ale alespoň si oživím spuštění webu :-)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od vlada
16. led 2021 16:43 #143556
Takže čas uzavřít toto vlákno.
Migrace na J3.5.1. proběhla na serveru bez problémů, včetně upgrade na J3.6.x Pak jsem zjistil, že nefunguje PhocaGallery. Zkusil jsem její Upgrade na 4.x, stále nic. Prázdná stránka v administraci i na frontendu.
Pak jsem už na lokále WAMP3.2 (PHP7.1.33) udělal upgrade Joomla na J3.9.x bez problémů. A ejhle, Phoca začala chybově reagovat. Z hlášek se dalo zjistit, že jí chybí tabulka _styles.
V této diskusi
www.joomlaportal.cz/forum/71-joomla-3-0-...a-joomla-3-nefunguje
je postup, jak ji vytvořit. POZOR, je tam chybička. Datum nesmí být 0000-00-00 00:00:00 ale stačí je VŠECHNY upravit na 0001-01-01 00:00:00.
A je to super.
Zdraví Vlada

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Rudolf
16. led 2021 17:24 #143557

Pak jsem zjistil, že nefunguje PhocaGallery


Při použití Jmigrátoru a addonu pro PhocaGallery (10 USD) při převodu J15 na J3 nic Phoca Gallery nehlásí a všechny kategorie i obrázky se převedou v pořádku bez problémů.

MiniJoomla! - www.minijoomla.org - eshop s rozšířením Joomla/VM
Email Manager - aplikace na správu šablon emailů pro VirtueMart
Easy Feeder - aplikace na generování XML/CSV feedů a napojení na ERP pro VM
PragueClassicconcert - portál pro prodej vstupenek na systému Joomla

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.