Přihlásit se

Pomalé načítání webu/občas nejde vůbec - error 500

11. dub 2018 07:33 #135088
Zdravím fórum,

Mohu zdejší Joomla uživatele poprosit o pomoc z webem, který je v Joomle 3.4

www.keblice.cz - pomalu se načítá a občas nejde web vůbec a hodí hlášku 500

Kontaktoval jsem webhosting, tam je prý vše ok.

Chtěl jsem také updatovat přes web na poslední Joomlu, ale také to nejde.

Děkuji předem moc za pomoc.

Sveta

11. dub 2018 09:59 #135090
Odpověď od Houbák
Zkuste web přenést zkušebně na nějaký jiný webhosting. Chyba 500 je nějaký problém na serveru, webhosting by vám měl říct, proč se tato chyba zobrazuje.

11. dub 2018 10:26 #135091
Odpověď od Ernst
zkuste přejmenovat .htaccess na něco jiného a zkuste to

11. dub 2018 14:13 - 11. dub 2018 14:45 #135095
Odpověď od Bart
Tipoval bych to na možný problém s nějakým rozšířením.

Podobný problém jsem již v minulosti shodou náhod také řešil u Joomly 1. 5 ( a také na webu obce). Z toho všeho usuzuji, že by problém mohl být s nějakým rozšíření (a případnou nekompatibilitou či prostě nějakou chybou různého charakteru v souvislosti s rozšířením). Administrace se mi načte bezproblémů (tedy stejný případ, který jsem již řešil).

Máte relativně zastaralou verzi Joomly, bylo by vhodné aktualizovat na novější verzi (po vyzkoušení funkčnosti někde bokem). Jakou verzi PHP používáte? Předběžně tu vidím Apache 2.2.22 a PHP 5.4.45, Debian.

Stránky se mi absolutně nenačtou - chybí i nějaká chybová hláška (nezobrazuje se mi ani chyba na straně serveru 5xx, tedy především 500)

Nástroje vývojáře
Code:
Znaková sada HTML dokumentu nebyla definována. Pokud dokument obsahuje znaky mimo rozsah US-ASCII, může se při určitých nastavení prohlížeče zobrazovat se zkomoleným keblice.cz textem. Znakovou sadu stránky je potřeba definovat na úrovni přenosového protokolu nebo v dokumentu.

Doplňuji:
Firefox Developer Edition - žádná hláška, prázdná stránka (bílá) (v nástrojích vývojáře hlásí chybu 500)
Edge - chyba 500

11. dub 2018 14:39 - 11. dub 2018 15:21 #135097
Odpověď od Bart
Doplňuji

Problém je tedy někde na úvodní (hlavní stránce). Předpokládám rozšíření nebo skript atp. (musíte vědět sám / sama) co se od doby nastaných problémů změnilo.

Problém na úvodní stránce:
Díky Google Cache jsem zjistil "mapu" / menu webu. Problém v ostatních položkách menu nevidím:

11. dub 2018 14:54 - 11. dub 2018 14:58 #135098
Odpověď od Bart
Ohledně rychlosti webu:
Načítání webu dost zpomaluje animace pod menu (obrázek kostela, má 568.3 kB, je relativně velký - na šířku má přes 3000 pixelů a chvíli trvá než se vykreslí) a další skripty. Byla by fajn i cache.

Viz výsledek Pingdom Tools . Prohlížeči, např. Firefox lze podobně web otestovat také (klávesa F12, Nástroje vývojáře).

Powered by Fórum