Pomalé načítání webu/občas nejde vůbec - error 500

Pavel Svetlik
11. dub 2018 07:33 #135088
Zdravím fórum,

Mohu zdejší Joomla uživatele poprosit o pomoc z webem, který je v Joomle 3.4

www.keblice.cz - pomalu se načítá a občas nejde web vůbec a hodí hlášku 500

Kontaktoval jsem webhosting, tam je prý vše ok.

Chtěl jsem také updatovat přes web na poslední Joomlu, ale také to nejde.

Děkuji předem moc za pomoc.

Sveta

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Houbák
11. dub 2018 09:59 #135090
Zkuste web přenést zkušebně na nějaký jiný webhosting. Chyba 500 je nějaký problém na serveru, webhosting by vám měl říct, proč se tato chyba zobrazuje.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
11. dub 2018 10:26 #135091
zkuste přejmenovat .htaccess na něco jiného a zkuste to

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bart
11. dub 2018 14:13 - 11. dub 2018 14:45 #135095
Tipoval bych to na možný problém s nějakým rozšířením.

Podobný problém jsem již v minulosti shodou náhod také řešil u Joomly 1. 5 ( a také na webu obce). Z toho všeho usuzuji, že by problém mohl být s nějakým rozšíření (a případnou nekompatibilitou či prostě nějakou chybou různého charakteru v souvislosti s rozšířením). Administrace se mi načte bezproblémů (tedy stejný případ, který jsem již řešil).

Máte relativně zastaralou verzi Joomly, bylo by vhodné aktualizovat na novější verzi (po vyzkoušení funkčnosti někde bokem). Jakou verzi PHP používáte? Předběžně tu vidím Apache 2.2.22 a PHP 5.4.45, Debian.

Stránky se mi absolutně nenačtou - chybí i nějaká chybová hláška (nezobrazuje se mi ani chyba na straně serveru 5xx, tedy především 500)

Nástroje vývojáře
Znaková sada HTML dokumentu nebyla definována. Pokud dokument obsahuje znaky mimo rozsah US-ASCII, může se při určitých nastavení prohlížeče zobrazovat se zkomoleným keblice.cz textem. Znakovou sadu stránky je potřeba definovat na úrovni přenosového protokolu nebo v dokumentu.

Doplňuji:
Firefox Developer Edition - žádná hláška, prázdná stránka (bílá) (v nástrojích vývojáře hlásí chybu 500)
Edge - chyba 500

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bart
11. dub 2018 14:39 - 11. dub 2018 15:21 #135097
Doplňuji

Problém je tedy někde na úvodní (hlavní stránce). Předpokládám rozšíření nebo skript atp. (musíte vědět sám / sama) co se od doby nastaných problémů změnilo.

Problém na úvodní stránce:
Díky Google Cache jsem zjistil "mapu" / menu webu. Problém v ostatních položkách menu nevidím:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bart
11. dub 2018 14:54 - 11. dub 2018 14:58 #135098
Ohledně rychlosti webu:
Načítání webu dost zpomaluje animace pod menu (obrázek kostela, má 568.3 kB, je relativně velký - na šířku má přes 3000 pixelů a chvíli trvá než se vykreslí) a další skripty. Byla by fajn i cache.

Viz výsledek Pingdom Tools . Prohlížeči, např. Firefox lze podobně web otestovat také (klávesa F12, Nástroje vývojáře).

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
11. dub 2018 18:08 #135104
Na tak zastaralém hostingu může být chyba kdekoli. Doporučuji nejprve aktualizovat:

PHP 7.0 +
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)

MySQL 5.5.3 +

(InnoDB support required)
MySQL používající starší `ext/mysql` PHP rozšíření nebude již podporováno, místo toho musí být použito MySQLi nebo PDO MySQL

A následně zaktualizovat Joomlu a rozšíření.

Takhle budete řešit třeba něco co ani nemusíte a za krátký čas vás to stejně čeká...

I'm sorry, my responses are limited...you must ask the right questions.
Poděkovali: Pavel Svetlik

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bart
11. dub 2018 18:21 #135105
Souhlasím Bongu - proto jsem se ptal na verzi PHP. Joomla 3.6 a vyšší už předpokládá spíše PHP7.

Zde technické požadavky

Nejprve kompletně zálohujte web. Možná to zní paranoidně, ale aspoň 2 zálohy bych udělal - kompletní. S tím, že je potřeba ověřit, zda je záloha vytvořena správně.

Pak bych se obrátil na webhosting o navýšení verze PHP na 7.0.x či 7.1.x. (nemám problém ani s PHP 7.2.x). Případně i Apache povýšit na 2.4.x.

Pak bych být Vámi řešil další věci.

1. Aktualizaci
2. Zálohování
Poděkovali: Bong

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Petr
12. dub 2018 06:35 #135111
Ještě doporučím nechat nastavít
HTTPS - řeší to Let's encrypt který je zadarmo, má sice omezenou platnost na 3 měsíce ale hosting jej umí automaticky prodloužit
HTTP/2 - kde nezáleží tolik na počtu dotazů a dokáže líp načítat rychleji scripty, styly z joomla rozšíření kterých je někdy na webu nespočet.
Poděkovali: Bong, Pavel Svetlik

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Pavel Svetlik
12. dub 2018 07:47 - 12. dub 2018 07:49 #135114
Zdravím,

Děkuji všem za pomoc a rady. To co píšete chápu, ale je to nad moje síly a čas. Nejsem v tom odborník. Byl by někdo prosím ochotný mi s tím vším pomoci - jsem ochotný i finančně přispět.

Předem děkuji.

Sveta

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Petr
12. dub 2018 19:50 #135119
PHP 7.x, HTTPS, HTTP/2 by měl vyřešit hosting když jim napíšete pokud nevyhoví tak bych je vyměnil. Mám odzkoušné Managed VPS od hostime.cz

Jinak můžeš ještě prohnat obrázky přez tinypng.com, což dokáže obrázky krásně optimalizovat hlavně ten kostel.jpg jak už tady zaznělo. Ten by zasloužit i zmenšít na nějakou rozumnou velikost např. 1980x

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bart
13. dub 2018 15:06 - 13. dub 2018 15:40 #135136
Článek z tohoto roku: Google: Webmasteři, do léta přejděte na HTTPS, nebo vaše weby označíme jako nebezpečné!

Z HTTPS se stává víceméně standard. A rozhodně doporučuji i kvůil HTTP/2 (který já osobně taky pokládám za standard, i když ne každý webhosting ho podporuje...přesto i když je nastaven certifikát pro HTTPS).

Info o HTTP/2

Ve zkratce řečeno - HTTP/2 podporuje většina distribucí linuxu (samozřejmě v potřebné konfiguraci) a MS Win 2016 (IIS10)
Ukázka z mého (testovacího) VPS s MS Windows Server 2016 Datacenter. (ikony mám posunuty vlevo, kvůli vzdálené ploše z mobilu :D)

Soubor přílohy:


Soubor přílohy:


Soubor přílohy:


Tip na pár doplňků pro Firefox na které jsem si našel a které dlouhodobě používám...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Linelabcz
13. dub 2018 17:29 #135137
Pokud se web načítá pomalu, třeba jen administrace, často bývá problém s tabulkou session. Myslím si, že to bude váš problém. Zkuste například: joomla-extensions.kubik-rubik.de/downloa...sion-killer/joomla-3

Linelab.cz Tvorba a správa webových stránek Joomla! LINELABOX Vytvořte si Joomla! šablony zdarma

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Rudolf Baláš
17. dub 2018 14:10 #135170
Web je špatně udělaný,

a žádný přechod na php7 Vám nepomůže.

1. Slideshow pod menu je fakticky ale fakticky špatně nastavené a ve své podstatě postrádá smysl, když je tam jen jeden obrázek - to ho můžete dát rovnou do šablony jako pozadí.
2. Další slideshow na články a opět špatně, je rozbité a rozbíjí to pravý sloupec a navíc vzniká ještě další slidedeshow úplně dole?

To to jsou hlavní důvody proč web čeká a má stráááášně dlouhý TFB, než začne s renderováním a vykreslením.

Odlaďte tohle a dostanete se na takových 5-6 sekund, což na web na šabloně bez optimalizace by mělo odpovídat vynaloženým nákladům na web.

Další úpravy dle diskutujících jsou možné, záleží na erudici admina a ekonomickému přínosu.
Poděkovali: Pavel Svetlik

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Pavel Svetlik
18. srp 2018 13:09 #136886
Pěkný den,

Stále nevyřešeno, úvodní stránka webu nejde už vůbec, další přímé linky ok, takže problém je v první hlavní stránce. Hledám někoho, kdo je ochotný pomoci a vyřešit i aktualizaci na last verzi joomly - přes auto aktualizaci to nejde.

Samozřejmě to nechci zdarma. Děkuji moc.

Sveta

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.