Zrušení index.php z URL - problém code 500

Karl
30. čen 2016 14:54 #127448
Pročetl jsem místní i cizí fóra ... a nedokážu stále pořešit problém code 500, který to vyhodí místo stránek.

localhost
nejnovější wamp
nejnovější Joomla 3.5.1
SEO nastavení
URL přátelské k vyhledávačům Ano
Použít přepis URL Ano
Přidat k URL příponu Ne

přjmenované htacces.txt na .htaccess
(tolik rada v bublině Joomly)
dle stackoverflow jsem myslím vyzkoušel všechny kombinace, kdy jsem odkomentoval
RewriteEngine On
zakomentoval Options + FollowSymLinks
a také ještě tu jednu volbu na konci souboru od(i)zakomentoval (teď nejsem u pc)

dále jsem se podíval do configu wampu a tam jsem našel jeden aktivní řádek volající script pro mod_rewrite ...

jsem amatér a pomalu mám pocit, že jsem vystřílel všechny možnosti, které druhým pomohli....
Chápu správně, že v .htaccess se nikde neuvádí jméno domén, jenom od/zakomentují různé volby?
Případně může mi někdo postnout svůj htaccess, kdy to funguje?

Webík je jednoduchý nemám tamcžádné rozšíření pro SEO a ani moc nechci... teď už mě to zajímá i poize z principu, kdy bych měl raději URL bez index.php

hélp plís
Kárl

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
30. čen 2016 15:00 #127449
htaccess funguje ten, co je v základní instalaci. Chyba 500 znamená, že server (tedy wamp) nepodporuje tento soubor, některou z direktiv v něm, nebo je v souboru cosi špatně.

Nahrajte tedy základní soubor z instalace - naběhne úvodní stránka? Pokud ne, zkuste v něm zakomentovat řádky Options. Pokud to nepomůže, podívejte se do nastavení WAMPP, jestli máte htaccess povolen (direktiva AllowOverride ).
Pokud naběhne úvodní stránka, a nefunguje SEF, pohrajte si s direktivou RewriteBase.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Karl
30. čen 2016 15:04 #127450
úvodní stránka nenaběhne...
ok zkusím to nastavení wampu
velmi děkuji za další možnost

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
30. čen 2016 21:32 #127454
na localhost nepoužívejte přepis url, to si zapněte až na webu

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Karl
01. čec 2016 13:34 #127460
tak ksem si to pěkně domrcasil... takže wamp budu reinstalovat

direktiva AllowOverride je v configu asi na 3místech
default
root adresář
cgi adredář

u root to byli nastaveno na all, takže jsem nastavil na all i default (directory /)
a nepomohlo to...

není to akutní, jak píše ernst, hlavní bude hosting, ale i tak...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od zpetr
01. čec 2016 17:10 #127461
Bych se vykašlal na "maturitu" z wampu použil bych Džumláčka a můžu se věnovat Joomle.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
01. čec 2016 20:07 #127462
já osobně jsem zjistil, že některý věci, třeba sobipro, ale i další běhaj jen pod xampp.
Jinak osobně používám více vertrigo
Poděkovali: Karl

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Karl
01. čec 2016 20:56 #127463
koukám že hlavou zeď neprorazím, zkusím Tvé tipy
díky
Kárl

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Karl
05. čec 2016 15:59 #127481
Tak jsem již s Jomlou na hostingu a stejný problém
Hosting: Savana 100
htaccess v nastavení povolené - podpora nevidí v ničem problém
a mě to stále háže 500 chybu
a to i když zakomentuji
Options +FollowSymlinks
Options -Indexes
htaccess z poslední Joomly 3.5.1 jsem přidal v příloze
Přílohy:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Karl
05. čec 2016 21:09 #127482
Tak vyřešeno. Na Savaně poradili.
Je potřeba zakomentovat i řádky
Options +FollowSymlinks
Options -Indexes

a také zakomentovat
IndexIgnore *

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.