Přihlásit se

V modulu se nezobrazují obrázky ve Firefoxu

01. úno 2016 13:04 #125588 od Radek Malík
V modulu se nezobrazují obrázky ve Firefoxu vytvořil uživatel Radek Malík
Zdravím. Chtěl bych poradit s následujícím problémem. Na své testovací stránky jsem chtěl vložit reklamní banner. Postupoval jsem následovným způsobem. Vytvořil jsem si nový modul s názvem Reklama s vlastním obsahem. Do něj jsem pak vložil reklamní banner, což je gif animace. Poté jsem modul zveřejnil a umístil do pravého sloupce mezi další moduly. Až potud vše fungovalo bez problémů. Jak jsem však zjistil, daný obrázek a je jedno, jestli je to gif, jpg či png, se mi korektně zobrazují pouze v IE a Chrome. Ve Firefoxu zůstává okno prázdné viz přiložené obrázky. Nevíte jakým způsobem to obejít? Předem díky za podněty a rady.
Přílohy:

Pro možnost přispívání do fóra se přihlaste.

01. úno 2016 13:16 #125589 od Ernst
Odpověď od Ernst
Bez odkazu na stránky toho moc nevykoukám, napište ho sem.
Bohužel každý prohlížeč má různé odlišnosti.
Problém může být zrovna v tom "vlastním obsahu".
Proč nepoužijete bannery přímo z joomly nebo třeba extensions.joomla.org/extension/flexbanner

Pro možnost přispívání do fóra se přihlaste.

01. úno 2016 13:29 #125594 od Radek Malík
Odpověď od Radek Malík

Pro možnost přispívání do fóra se přihlaste.

01. úno 2016 13:38 #125595 od Radek Malík
Odpověď od Radek Malík
Hmmm, tak jsem zjistil zajímavou věc. Když jsem ve správci médií vytvořil vlastní adresář reklama a vložil do něj tento bannerový obrázek, tak to nešlo zobrazit. Tak jsem zkušebně vložil ten obrázek do adresáře banners, který je v joomle od instalace a najednou to zobrazit jde. Kontroloval jsem přes ftp atributy adresářů a jsou naprosto totožné. Tak nechápu proč to nejde.

Pro možnost přispívání do fóra se přihlaste.

01. úno 2016 13:39 - 01. úno 2016 13:41 #125596 od Ernst
Odpověď od Ernst
tak první poznatek:
ve firefoxu se reklama zobrazuje, v chrome ne.
v chrome to píše Failed to load resource: the server responded with a status of 404 (Not Found) - www.copytechnik.org/images/reklama/canon_iR1435.gif

to znamená, že tam ten gif není nebo není přístupný

teď po refreš se zobrazuje správně v obou prohlížečích

Pro možnost přispívání do fóra se přihlaste.

01. úno 2016 13:47 #125598 od Radek Malík
Odpověď od Radek Malík
To nenehrátí obrázku bude asi tím, jak si s tím tady hraju a měním adresy obrázků. Teď už by to mělo jít bez problémů.

Pro možnost přispívání do fóra se přihlaste.

Powered by Fórum