Spatna url pri zapnuti SEF

Jakub
14. zář 2013 01:02 #111020
Zdravim, dokaze mi prosim nekdo poradit, jak se zbavit spatne url pri zapnuti SEF v global configuration? Predtim to neslo vubec a kdyz jsem doplnil do $live_site = 'http://url'; tak to alespon nehazi chybu, ale stejne je v url vic polozek nez bych chtel. Asi dulezita vec bude, ze jsme tvoril stranky na localhostu a pak je teprve akeebou prenesl na server. Driv mi to zadna stranka nedela, ale nikdy jsem ji neprenasel z localu.

Priklad po kliknuti na Create an account www.kontakty-na-firmy.cz/index.php/compo...s/?view=registration
stranky bezi na .kontakty-na-firmy.cz
joomla 3.1.5.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
14. zář 2013 05:27 #111045
Nepoužíváte žádné SEF rozšíření, ba dokonce ani nemáte zapnuto 'Použít přepis URL' a nastavený .htaccess. Výsledek je tedy přesně takový, jak požadujete. S přesunem z local to nemá nic společného.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jakub
15. zář 2013 22:35 #111105
Dekuji za odpoved. Kdyz zapnu URL prepis, stranky se nezobrazi vubec kontakty-na-firmy.cz/component/users/?view=registration

Myslel jsem, ze staci pouze zapnout Search Engine Friendly URLs v globalnim nastaveni. Je k tomu tedy potreba jeste nejaky plugin nebo komponenta? Dekuji.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
15. zář 2013 23:57 #111107
Není k tomu potřeba nic jiného, než si přečíst poznámku u možností, které v globálním nastavení zapínáte. Hlavně ty s velkým žlutým vykříčníkem ;)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jakub
16. zář 2013 14:44 #111131
Na apache to bezi, takze jsem prejmenoval htaccess.txt na .htaccess a bezi to na linuxu, takze web.confing.txt jsem nemenil. Jine nastaveni nevidim.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
16. zář 2013 20:14 #111142
Pak musíte zkontrolovat, zda Váš hosting podporuje htaccess. Pokud ano, zda podporuje všechna nastavení, která ve výchozím htaccess Joomly jsou. Zkuste v něm např. zakomentovat řádek
Options +FollowSymLinks

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jakub
17. zář 2013 00:19 #111153
Bohuzel nepomohlo.

Spis mi nejde do hlavy proc to generuje url /component/users/?view=registration

Proc je tam to component a user.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
17. zář 2013 08:38 #111156
Máte v plánu se dostat se stránkou přihlášení na čelní pozice ve vyhledávačích? Pokud ne pusťte to klidně z hlavy :-).

Jestli vám jde o to, aby i ta nejposlednější URL byla tiptop, musíte použít nějaké SEF rozšíření s případnými pluginy (často placenými) pro rozšíření, která používáte.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
17. zář 2013 14:40 #111174
Nebo si založte menu ukazující na stránku přihlášení.

S tím htaccess - kontaktujte Váš hosting, jestli ho vůbec máte povolený. Pokud ne, vypněte si v globálním nastavení Joomly možnost používat přepsi url, a odkzay pak bude mít ve tvaru /index.php/components/user

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
18. zář 2013 06:06 #111194
Váš hosting vyžaduje .htaccess nastavit. Upravte jej tedy:

odkomentujte řádek RewriteEngine On, takto:
RewriteEngine On
zakomentujte řádek Options +FollowSymLinks, takto:
# Options +FollowSymLinks
odkomentujte řádek RewriteBase /, takto:
RewriteBase /

Za předpokladu, že máte vše nahráno na správných místech a .htaccess upravujete v nějakém vhodném editoru bude vše fungovat. Viz. nápověda

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.