Přihlásit se

Aktualizace na J4 s češtinou

28. led 2022 21:38 #145741 od Cony
Aktualizace na J4 s češtinou vytvořil uživatel Cony
V češtině pro Joomla 3 je použitá starodávná třída JString, která v Joomla 4 už byla odstraněna.
Je to ve funkci transliterate v obou balíčcích jak pro administraci, tak pro web.
V důsledku toho sice aktualizace z Joomla 3 na 4 proběhne, ale polovina administrace je pak nefunkční.

Doporučil bych zaměnit třídu za \Joomla\String\StringHelper, ta funguje od verze 3.4 z roku 2014.

Pro možnost přispívání do fóra se přihlaste.

28. led 2022 22:08 #145742 od Bong
Odpověď od Bong
Obávám se, že to může být problém. Je to zrovna část php souboru, která není v administraci překladu dostupná.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra se přihlaste.

28. led 2022 22:14 #145743 od Cony
Odpověď od Cony
Aha :) V tom případě bych někam hodil doporučení na přepnutí se do angličtiny před aktualizací na J4, chyba totiž znemožní vlézt do menu Systém, nejde tedy jednoduše češtinu aktualizovat až po upgrade...

Pro možnost přispívání do fóra se přihlaste.

28. led 2022 22:22 - 28. led 2022 22:23 #145744 od Vašek H.
Odpověď od Vašek H.
Když jsem to zkoušel, tak přepnutí do angličtiny také nepomohlo, systém nefungoval a chybu hlásil... na oficiálním fóru se to objevilo i u mnoha jiných jazyků, ale nabízené řešení mě nepomohlo. Čeština tam byla zdvojená 3.10. a 4.0.5

Pro možnost přispívání do fóra se přihlaste.

28. led 2022 22:54 #145745 od Bong
Odpověď od Bong
To by mohlo řešit odinstalování češtiny ještě před upgradem.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra se přihlaste.

28. led 2022 23:26 #145746 od Cony
Odpověď od Cony
A nebo tak :) Stejně tak je potřeba odinstalovat Joomla plugin Geshi, ten mi nějak předinstlační kontrola nehlásila :(

Pro možnost přispívání do fóra se přihlaste.

Powered by Fórum