Gantry 5 - Error po změně verze PHP

Mr.TExas
12. lis 2018 20:02 #137628
Dobrý den.

Chtěl jsem požádat o pomoc, zda-li se někdo z Vás již setkal chybovým hlášením:
Failed to load '' template: Please install Gantry 5 Framework!

V tuto chvíli mám ve vývoji 3 weby se stejnou šablonou.
Po změně na novější verzi PHP (původní 5.6.27, na ozkoušení novější 7.0.32) se na jednom z nich bohužel po načtení hlavní stránky objeví tato hláška. Na zbytku změna proběhla bez problému. Po změně na starší verzi 5.6.27 hlášení zmizelo. Gantry 5 je aktualizováno na nejnovější 5.4.26.
Nesetkal se někdo z vás s tímto problémem? Případně nějaké konkrétní řešení?


Díky a s pozdravem Mr.TExas

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
12. lis 2018 20:13 - 12. lis 2018 20:13 #137630
je to někde vidět?
Zkoušel jste php 7.1.?
Jakou máte verzi Gantry 5? Poslední je 5.4.26?
Jakou máte verzi joomly?
Kde hostujete?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Mr.TExas
12. lis 2018 20:29 #137631
Dobrý den.

Děkuji za odpověď.
Vidět momentálně ne, web je zamčený.
PHP 7.1 jsem prozaítm nezkoušel ,nicméně se obávám, že problém bude stejný.
Jak je psáno výše, verze Gantry5 je 5.4.26 - tedy poslední verze.
Verze Joomly je 3.9.0.
Hosting je na vlastních serverech.

Řekl bych, že se jedná o problém konkrétní instalace (zřejmě). Dvě další instalace, se stejnými verzemi běží bez chyby.
Web momentálně běží, tudíž to není žádná horká chyba, nicméně by mě zajímalo, jestli se s tím někdo setkal?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
12. lis 2018 21:34 - 12. lis 2018 21:40 #137633
já ne, ale z toho co píšete to vypadá, že nelze načíst framework.
Zkuste ho přeinstalovat.
Zkontrolujte si oprávnění souborů a složek.
Pokud možno povyšte PHP na 7.1., 7.0. už není podporováno. http://php.net/supported-versions.php
Udělejte kontrolu databáze a vyčistěte mezipaměť.
Zkuste zkontrolovat "pátráním" zda vám tam nic nechybí.
Zkontrolujte také rozšíření - databáze.

Hlásí to i při jiné šabloně?
Máte zapnutý error log a píše to něco do něj?

pokud alespoň dočasně neumožníte přístup na web, asi vám více nemohu poradit

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Mr.TExas
13. lis 2018 06:32 #137634
Dnes ráno i s verzí 7.1, případně 7.2. bohužel stejný problém.
Zkusím popátrat, případně přeinstalovat Gantry, jestli nepomůže.

Díky

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.