Nový článek

klucon
09. čec 2018 10:01 #136563
Ahoj komunito,
z ničeho nic se mi objevuje chyba, když chci přidat nový článek nebo upravit stávající.

V příloze posílám screen.

Jedná se o J! 3.6.4. Nemohu aktualizovat, protože mi to vyšší Joomla než 3.6.5 kompletně rozhodí vzhled a šablona již není aktualizovaná. Pracuji na nové šabloně, ale do té doby bych rád zprovoznil ty články.

Díky za odpovědi

klucon
Přílohy:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od H13
09. čec 2018 14:34 #136568
Ahoj,

zkus si zapnout php error reporting na maximum nebo se podívej do errorLog na přesnou chybovou hlášku, aby jsi věděl, která část ti tu chybu dělá ( www.phoca.cz/documents/16-joomla/336-how...g-php-errors-on-site ). Pravděpodobně něco zastaralýho volá funkci, která už neexistuje - zde je podobný případ:
forum.joomla.org/viewtopic.php?t=955135

Phoca Gallery - http://www.phoca.cz/phocagallery - obrázková galerie (Joomla!)
Phoca Guestbook - http://www.phoca.cz/phocaguestbook - kniha návštěv (Joomla!)
Phoca Download - http://www.phoca.cz/phocadownload - stahování souborů (Joomla!)
Phoca Cart - http://www.phoca.cz/phocacart - e-shop,...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od klucon
10. čec 2018 18:24 #136608
zapnul jsem si hlášení chyb na maximum a zároveň jsem povolil ladění chyb a zobrazilo se mi:

JHtmlJquery::token not found.
Call stack
# Function Location
1 JApplicationCms->execute() JROOT/administrator/index.php:51
2 JApplicationAdministrator->doExecute() JROOT/libraries/cms/application/cms.php:261
3 JApplicationAdministrator->dispatch() JROOT/libraries/cms/application/administrator.php:152
4 JComponentHelper::renderComponent() JROOT/libraries/cms/application/administrator.php:98
5 JComponentHelper::executeComponent() JROOT/libraries/cms/component/helper.php:380
6 require_once() JROOT/libraries/cms/component/helper.php:405
7 JControllerLegacy->execute() JROOT/administrator/components/com_content/content.php:21
8 ContentController->display() JROOT/libraries/legacy/controller/legacy.php:702
9 JControllerLegacy->display() JROOT/administrator/components/com_content/controller.php:52
10 ContentViewArticle->display() JROOT/libraries/legacy/controller/legacy.php:664
11 JError::raiseError() JROOT/administrator/components/com_content/views/article/view.html.php:58
12 JError::raise() JROOT/libraries/legacy/error/error.php:277

Nějak nemohu přijít na to, co by tu funkci mohlo volat :(

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
12. čec 2018 20:59 #136626
jaký výchozí editor používáte? JCE nebo něco jiného?

Může to dělat nějaký plugin který proacuje v editoru, můžete podezřelé zkusit vypínat.

Neměnil jste verzi PHP?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od klucon
12. čec 2018 21:19 #136628
ano, používá se JCE, ale ten je nainstalovaný od začátku, co jsem ten web postavil.
mno udělal jsem si pro test zálohu webu a nainstaloval na jiné subdoméně, celou jsem ji zaktualizoval a vše funguje jak má..

Takže se něco pokazilo zničeho nic. Jen dodám, že všechny komponenty a nebo šablony byly řádně zaplacené a nic nepochází z černého trhu..

Přesto mám podezření na Jcomments, Je to silně zastaralá komponenta a házelo mi to různé chyby po zapnutí bugu.

Ale tak zatím si stavím web na té jiné subdoméně, kde jsem odinstaloval nepotřebné pluginy, komponenty a moduly.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.