problém

David
01. úno 2018 11:20 #134007
Dobrý den,

provozuji joomlu již mnoho letna forspi. Nicméně se mi objevuje na serveru tohle:
Parse error: syntax error, unexpected T_VARIABLE in ............/home/www/libraries/joomla/cache/storage.php on line 1

nic nefunguje, nemůžu se nikam dostat. Hosting forpsi, záloha obnovit nejde, mám trochu podezření, že vím, proč se to stalo, ale není to zas tak důležité. MySQL i nastavení v confuguratin.php se zdá být v pořádku. Nejradši bych to přeinstaloval, ale potřeboval bych, aby vše zůstalo stejné, tj. data i nastavení.

Myslíte, že se s tím dá něco dělat?

Díky

David

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
01. úno 2018 11:28 #134009
Dá se všechno, ale vy musíte poskytnout nějaké informace.

Verze Joomly, PHP,...?

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od David
01. úno 2018 11:49 #134012
No to je problém, kdybych věděl přesně, určitě to už napíšu. Verze Joomly bude něco novějšího, na stránkách Forpsi nabízejí určitě 3.6.5. Pokud jde o PHP 5.6 / 5.5 / 5.4 / 5.3 (v režimu FastCGI).

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
01. úno 2018 12:12 - 01. úno 2018 12:14 #134014
Co nabízí Forpsi není nic platné... Když si Joomlu neaktualizujete, tak se nesmíte divit, že nefunguje.

Podle všeho tam nemáte novější verzi než 3.7.5

  1. Zazálohujte stav, který tam máte. Tedy zazálohujte soubory z FTP a databázi.
  2. Přes FTP si do rootu Joomly nahrajte plný instalační ZIP verze 3.6.5 a soubor kickstart.php od Akeeba Backup.
  3. V prohlížeči zavolejte kickstart.php a jeho pomocí rozbalte instalační ZIP.
  4. Přes FTP smažte složku installation.
  5. Zkuste se přihlásit do administrace Joomly.
  6. Zkuste nainstalovat Akeeba Backup a vytvořit si řádnou zálohu.
  7. Zaktualizujte Joomlu pomocí automatických aktualizací (Komponenty - Aktualizace Joomla). Až na poslední verzi 3.8.4.
  8. Zkontrolujte a opravte databázi (Rozšíření - Spravovat - Databáze).
  9. Vytvořte zálohu Akeeba Backup.
  10. Zaktualizujte všechna rozšíření třetích stran
  11. Vytvořte zálohu Akeeba Backup.
Zálohu si na PC pak stáhněte přes FTP. Na FTP smažte instalační ZIP Joomly a kickstart.php

Dále můžete pokračovat změnou všech hesel, kontrolou na zavirování a zabezpečením.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.