Nefunguje vyhledávání

Zbyňďátor
28. pro 2017 19:23 #133527
Zdravím ve spolek.
Na Joomle 3.8.3 (webhosting Wedos) mi přestalo fungovat (nevím kdy) vyhledávání. Při zadání neprázdného dotazu dostanu hlášku "Chyba: 0 - Call to a member function getState() on boolean" viz www.pelechy.cz ". Pan Google nepomohl. Už si s tím hraju druhej den a došly mi nápady.
Nenapadá vás řešení? Předem díky za rady.

Přílohy:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
29. pro 2017 12:12 #133531
máte v nějakém skrytém menu nastavenu vyhledávací stránku?
Nejde vám ani slide.
To se stalo samo od sebe nebo jste něco aktualizoval?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Zbyňďátor
29. pro 2017 12:31 #133534
1.) Ve skrytém menu není - když zadám nulovou hodnotu při vyhledávání, stránka se zobrazí.
2.) Nejde vám ani slide. - Nerozumím
3.) Nevím kdy se to stalo, přišel jsem na problém náhodou. Joomlu aktualizuji pravidelně.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
29. pro 2017 13:43 - 29. pro 2017 14:21 #133536
Copak Joomlu, ale i rozšíření je třeba aktualizovat. Mrkněte co vám to ukazuje za chyby:






Začněte tím, že povypínáte pluginy a moduly třetích stran (slide, powr, facebook,..)... a hned uvidíte, který to dělá.

OT.: V URL se vám objevuje /domains/pelechy.cz/index.php, něco máte špatně. Nechybí vám náhodou originál .htaccess v adresáři WWW, nebo doména v configuration.php - public $live_site = '';?
Ohavného index.php se zbavíte pomocí .htaccess Joomly a nastavením SEO v Globálním nastavení Joomly.
Mimochodem ten FB dole na stránce je také příšernost, zkuste třeba Perfect Everything in Everyway.

I'm sorry, my responses are limited...you must ask the right questions.
Přílohy:
Poděkovali: Zbyňďátor

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Zbyňďátor
29. pro 2017 17:45 #133541
Pes byl zakopanej v pluginu "Hledat - DPCalenar" - ten jsem "samozřejmě" jako jeden z mála při testování nevypnul (tluču hlavou o zeď :-(). Po vypnutí už vyhledávání funguje. FB na konci je děs, vím, ale nevěděl jsem o lepším řešení. Bongu díky za rady! Zapracuji na jejich realizaci.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.