Migrace na novou verzi

Radek
26. kvě 2017 13:21 #131538
Ahoj lidi, částečně tato otázka patří do šablony, a částečně i sem... Mám joomlu verzi 2.5.2.8 a rád bych kvůli bezpečnosti migroval na novější verzi... ALE
1) Mám zakoupenou šablonu od YOOTHEME yoo_revista (1.0.3), která je sice responzivní, ale nejsem si jist jestli by fungovala na verzi 3.4<
2) mám zakoupené rozšíření ZOO pokud bych přemigroval na novou verzi
  • musel bych zakoupit novou verzi ZOO?
  • a jak by to bylo se stávající databází?
  • zůstalo by vše při starém?
  • nebo bych musel naládaovat data znovu?

Mohl by jste se někdo podívat a říct jestli migrace lze provést "bez komplikací"?

Moje stránky jsou na www.maser.cz (pokud by to někdo bral jako reklamu, klidně odkaz šmažte)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
26. kvě 2017 17:15 #131545
1. šablony pro J2.5 lze zpravidla provozovat na J3x po úpravě, viz. www.google.cz/search?q=how+to+migrate+template+J2.5+to+J3
2. ZOO v zakoupené verzi vám bude fungovat pokud je s J3 kompatibilní, pokud není, pak musíte zakoupit aktualizaci, nebo verzi novou. Dle licenční politiky autorů.
3. Stávající databáze se migrují, tabulky Joomly automaticky při aktualizaci, nebo třeba pomocí migrátoru. Tabulky rozšíření se migrují třeba také pomocí migrátorů, pokud jsou podporovány, nebo je pro postup migrace na stránkách rozšíření návod.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
01. čen 2017 21:20 #131611
Dá se migrace udělat "obráceně" tzn. nainstaluju si někam (např na XMAP) novou Joomlu a pak pomocí nějaké komponenty natáhnu data podle toho jaká chci že si vyberu? Například default (uživatele, články ad.) a pro další komponenty?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od zpetr
01. čen 2017 22:16 #131612
já používal j2xml
extensions.joomla.org/extension/j2xml/
mastil jsme jen články a kategorie a dělá co má.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
21. čen 2017 00:24 #131744
ještě jsem daaaaavno použival nějakou komponent (nevim jak se jmenovala), která propojila dvoje stránky respektive databáze... princip byl, že se nainstalovala nová verze joomly a propojila se se starou verzi a ta komponenta sesynchronizovala databáze...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
21. čen 2017 11:40 #131749
uz vim jmenovala se ta komponenta neco jako xcloner backup... nebo tak nejak, ale nemohu ji najit...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
21. čen 2017 14:54 #131750

raki napsal: uz vim jmenovala se ta komponenta neco jako xcloner backup... nebo tak nejak, ale nemohu ji najit...

XCloner je spíš pro zálohování nebo přenesení a není určen jen pro Joomlu. Najdete ho na xcloner.com

Osobně používám pro migrace komponenty SP Upgrade a vyjímečně na něco j2XML. Ale už jsem narazil na weby, se kterými si migrátory neporadily a nastopila ruční práce :-)

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.