Joomla 3.7.1

Cony
12. kvě 2017 17:43 - 12. kvě 2017 17:43 #131362
Ve středu 17tého května přibližně v 14:00 UTC bude vydána Joomla! 3.7.1, obsahuící důležitou bezpečnostní záplatu.

Aktualizujte!

Zdroj

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od MaK.
12. kvě 2017 17:46 #131363
Ve středu 17. 5. vyjde prý důležitá záplata – Joomla! 3.7.1

Tak se připravte na upgrade, více info: www.joomla.org/announcements/release-new...pre-release-371.html

MaK.

--- -- -

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od MaK.
12. kvě 2017 17:47 #131364
Ha, Cony, byl jsi o 3 minuty rychlejší :-)

Admini, můj post tedy prosím smažte B)

--- -- -

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Karel Neugebauer jr. - itx.cz
13. kvě 2017 08:26 #131369
Tragické, kolik security problému se objevuje v posledních letech. Odpovídá to bohužel nevalné kvalitě vývoje a tomu, že Joomla už není co bývala. :-( Security by mělo být na prvním místě a tomu by se měli hlavně vývojáři věnovat, ne pochybným features.

http://itx.cz - komplexní služby v IT a vše pro Joomla - šablony, komponenty, moduly, servis ... http://hostime.cz - webhosting nejen s podporou Joomla

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od zpetr
13. kvě 2017 18:01 #131374
A nebo se zlepšuje ta "temná" strana ;o)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
13. kvě 2017 19:23 #131376

XarlieN napsal: Tragické, kolik security problému se objevuje v posledních letech.

Bohužel nejen security. V Joomle 3.7 jsem za tu chvilku narazil na poměrně hodně nefunkčních věcí
- nejde ukládat články s češtinou, pokud máte nižší práva (resp. nastavené filtorvání html)
- špatné routování pro kategorie - projeví se na vícejazyčných stránkách při nastavených asociacích
- Fields typu list nefungují, pokud v nich je čeština

Navíc nové funkce typu multilingual assistent jsem buď nepochopil, nebo mi prostě nefungujou. Na to kolik má Joomla automatizovaných testů a bůhví čeho opravdu nic moc...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od radek
13. kvě 2017 20:55 #131377
Kdo vi, kam Joomla smeruje a jak to dopadne, nechtel bych se ucit zase neco jinyho. Pry zaziva docela velky snizeni poctu instalaci. Ostatne to potvrzuji trendy u velkych vyrobcu sablon, kde se z mesicnich vydavani sablon prechazi na neurcite obdobi a hlavne se vyrobci zameruji na pagebuildery.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od MaK.
13. kvě 2017 21:44 #131378
CMS Joomla! – to je podle mě dnes tak docela divočina, spíš hlavně pro „punkové“ hrátky s webem :) Je otázkou, zda je takový systém ještě vůbec využitelný pro ostré nasazení a podnikání.

Na Joomle funguju od verze 1.5, už cca 10 let, ale musím bohužel souhlasit s tím, že v posledních letech je to nějaké „jiné“. Na jednu stranu se vývoj dost urychlil, je hromada nových funkcí, což je super, ale s tím se zase nabalilo hodně bugů a následných nutných záplat.

S dalšími a dalšími verzemi pak přestávají fungovat některá rozšíření. Provoz webů se tím prodražuje – platím si dost rozšíření, ale po roce předplatného už jsou zastaralá, protože Joomla! měla mezitím XY upgrade.

Nevím proč, ale s dalším upgrade 3.7.1 mi v mysli vytanul tento rozhovor – berte prosím hodně hodně s rezervou
:)

Když pomyslím, jak frčí jednička CMS – svět WordPress – hromada pluginů a fičur i pro české prostředí, hodně moc vychytávek, návazných řešení, pravidelné srazy komunity v mnoha městech ČR,… – tak je mi tak nějak z té Joomly smutno :unsure:

MaK.

--- -- -

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od H13
16. kvě 2017 14:14 - 16. kvě 2017 14:22 #131403
Ahoj,
Když pomyslím, jak frčí jednička CMS – svět WordPress – hromada pluginů a fičur i pro české prostředí, hodně moc vychytávek

je to prostě tak, že Wordpress jde směrem co nejméně změn, zatímco Joomla! se snaží implementovat co nejnovější funkce (v rámci možností).

Pokud je někdo programátor a koukne se do kódu Wordpressu a Joomly!, pak asi nemá cenu se dál vyjadřovat. Na jednu stranu mě jako vývojáře rozšíření vůbec nedělají radost nové vlastnosti, které porušují zpětnou kompatibilitu, apod. Na druhou stranu, většinou dostanu logický vysvětlení, proč k tomu muselo dojít.

Stejně tak s chybama v nových verzí. Hodně nových věcí se přidá a nikdo není ochoten testovat Beta verzi. Pak si na web nainstaluje Stable a diví se, že jsou tam chyby. Vidím to na Twitteru, Core vývojáři se snaží, aby lidi testovali Beta a RC verze, ale feedback žádnej, prostě nikomu se nechce přidat ruku k dílu, jen prostě stáhnout nejnovější stable a nestarat se.

To že verze X.0.1 - až X.0.3 je v podstatě ještě Beta, to je tady, dá se říct, od začátku. Na produkční stránku většinou instalovat až verzi x.x.3. Do toho má Joomla! silnej bezpečnostní tým, to znamená, že se často mění verze kvůli bezpečnosti - a to je spíš pozitivní než negativní. A neřekl bych, že by na tom byl Wordpress nebo kdokoliv jinej líp (viz. tisíce napadených Worpress instalací v nedávné době)

Já osobně jsem velký a aktivní kritik Joomly!, ale tyto "poporodní bolesti" u nových verzí jsou prostě v době, kdy nikdo nechce testovat, normální. Protože jinak by se čekalo s Betou minimálně rok.

Co se týče Worpressu, tak v poslední době vnímám spíš opak. Nadšení z jednoduchosti a poté pomalé opadání nadšení vystřídané otázkami, zda kvůli limitům, o kterých se na začátku nevědělo, nepřejít na jiný systém. Typicky: "Mě se líbí, že napíšu článek a on je hned zveřejněný - na začátku, po určité době - a nešlo by nějak zařídit, abych si mohl tvořit menu odkazy tam, kde přesně potřebuji - a po delší době - a nešlo by to, aby to fungovalo jako v Joomle! " ...

Já osobně nejsem nadšenej, že musím všechny rozšíření neustále a pravidelně měnit - kvůli novým funkcím (např. PHP -> Joomla -> ...), ale když přemýšlím, že by to u Worpressu běželo celou dobu a že by tam byl např. zastaralej kód pro PHP 3 nebo PHP 4, co by tam ještě bez problému běžel a že jednou by se prostě stalo, že i Wordpress musí jít dopředu a že bych pak vlastně musel psát vše od znovu, no nevím.

Například Joomla! a její uživatelé mě nutí, aby byl můj PHP kód už nyní kombatibilnís PHP 7.1, na čemž momentálně dělám. Je to náročný, ale na druhou stranu, rozšíření jsou stále updatována a podporují nejnovější funkce a standardy. A to stejné nás čeká v Joomla! 4, tam to bude na straně SQL.

Náročné, jak píšeš "divočina", ale prostě držíme krok s dobou. Ideální to není, některé funkce v core jsou opravdu zbytečné, ale i o tom se hodně mezi core vývojáři diskutuje.

Phoca Gallery - http://www.phoca.cz/phocagallery - obrázková galerie (Joomla!)
Phoca Guestbook - http://www.phoca.cz/phocaguestbook - kniha návštěv (Joomla!)
Phoca Download - http://www.phoca.cz/phocadownload - stahování souborů (Joomla!)
Phoca Cart - http://www.phoca.cz/phocacart - e-shop,...
Poděkovali: Cony, Bong

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od radek
17. kvě 2017 07:58 #131410
Zajimavy informace. Ja treba rad zkousim novy veci. Pritom za snad 10 let, co Joomlu pouzivam, jsem se nesetkal s moznosti testovat betu.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
17. kvě 2017 08:45 #131411

radek178 napsal: Pritom za snad 10 let, co Joomlu pouzivam, jsem se nesetkal s moznosti testovat betu.

Ale to je úplně jednoduchý. V možnostech komponenty "Aktualizace Joomla" si lze zvolit, jaký kanál pro aktualizace používat. Např. teď už je v kanálu Testování možnost instalace Joomla 3.7.1RC2.

Nebo se dá zadat vlastní URL, seznam adres pro následující verze (aktuálně 3.8, 3.9 a 4.0) je zde .

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od MaK.
17. kvě 2017 10:13 #131412
1. rozšířené doporučení, ale neoficiální, zde slovy H13: „To že verze X.0.1 - až X.0.3 je v podstatě ještě Beta, to je tady, dá se říct, od začátku.

2. doporučení, oficiální přímo z Joomly: „Joomla! 3.7.1 - Important Security Announcement!

Působí to na mě asi takto: Když uživatel upgraduje, tak jeho problém, že mu x věcí pak nefunguje, protože mohl počkat aspoň na 3.7.3, jelikož první verze jsou asi nedoladěné. Ale když neupgraduje, hrozí mu nebezpečí kvůli bezpečnostní díře.

Jak se v tom vyznat? Co tedy doporučují ostřílení odborníci? Zůstat na 3.6.x, odolat lákadlům a novým funkcím nové řady a čekat až na 3.7.3–3.7.4?

MaK.

--- -- -

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
17. kvě 2017 10:46 #131413
Počkal bych, co je to za chybu. Dozvíme se to za pár hodin. Ale píší, že je to chyba kritická. Pokud ano, s aktualizací bych neváhal, dnes jsou roboti schopný napadnout stránku během pár hodin po vydání aktualizace. Třeba to bude chyba týkající se jen 3.7.0, pak můžete čekat dál...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od H13
17. kvě 2017 12:08 - 17. kvě 2017 12:13 #131415

Jak se v tom vyznat? Co tedy doporučují ostřílení odborníci? Zůstat na 3.6.x, odolat lákadlům a novým funkcím nové řady a čekat až na 3.7.3–3.7.4?


Vždy záleží na konkrétní situaci.

- Pokud se nic neděje, nejde o bezpečnostní problém - klidně počkat na verzi 3.7.3 a více
- Pokud do toho vejde bezpečnostní problém, zase je dobré vědět - jestli postihuje jen verzi 3.7 nebo i starší.
- Pokud i starší - 3.6.x - je lépe upgradovat (i s tím, že se v nové verzi může objevit malý bug - lepší malý bug než bezpečnostní problém - kolikrát ty menší bugy vůbec neovlivňují chod frontendu, což je to nejdůležitější)
- Pokud se víc vyznám, počkám si na informace o tom, o jakou chybu se jedná, pokud mě neovlivňuje (chyba vlastnosti, kterou nepoužívám), pak opět můžu počkat.

Takže jak píše Cony, počkat si na informace o tom, jaká chyba to je a kde všude se vyskytuje a poté se rozhodnout.

1. rozšířené doporučení, ale neoficiální, zde slovy H13: „To že verze X.0.1 - až X.0.3 je v podstatě ještě Beta, to je tady, dá se říct, od začátku.“

Tohle neplatí jen pro Joomlu!, platí to všeobecně, pro každý software a dokonce jsem se s tím setkal i u aut. Jsou lidi, co ti řeknou, že si nemáš kupovat nové auto, které bylo vyrobené na nové lince a že máš počkat nějakou dobu, než se vychytají "mouchy". A někde to trvá i celou jednu řadu, a dokonce i výrobce se chlubí tím, že v druhé řadě vylepšil ty části, co byly v první řadě problematické.

Phoca Gallery - http://www.phoca.cz/phocagallery - obrázková galerie (Joomla!)
Phoca Guestbook - http://www.phoca.cz/phocaguestbook - kniha návštěv (Joomla!)
Phoca Download - http://www.phoca.cz/phocadownload - stahování souborů (Joomla!)
Phoca Cart - http://www.phoca.cz/phocacart - e-shop,...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od radek
17. kvě 2017 12:44 #131416

Cony napsal:

radek178 napsal: Pritom za snad 10 let, co Joomlu pouzivam, jsem se nesetkal s moznosti testovat betu.

Ale to je úplně jednoduchý. V možnostech komponenty "Aktualizace Joomla" si lze zvolit, jaký kanál pro aktualizace používat. Např. teď už je v kanálu Testování možnost instalace Joomla 3.7.1RC2.

Nebo se dá zadat vlastní URL, seznam adres pro následující verze (aktuálně 3.8, 3.9 a 4.0) je zde .


To ja vim, ze to tam v Joomle je, ale ja to myslel trosku jinak. Ja to myslel hlavne tak, ze o tom, ze muzes testovat Betu, se nikde moc nedozvis. Nedozvis se, ze Joomla hleda betatestery nebo, ze jich ma nedostatek. Ja u spousty programu zkousel bety, protoze jsem se o moznosti testovat betu viditelne odzvedel na jejich webu nebo nekde jinde. Za tech cca 12 let, co jsem s Joomlou, jsem se o tom asi nikde nedozvedel.

Taky nejsem programator, ale hledal bych betu, ne RC verzi, to prece neni beta, ale release candidate. Navic mam pocit, ze mne to tam snad nabizelo kdysi i alfu. Uz nevim, ale o tom neni ta moje myslenka. Ta je o tom, ze BFU ani pokorcilejsi BFU, se jen tak nedozvi, ze muze delat beta testera.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.