Přihlásit se

Jak vyřešit problémy s Query?

12. kvě 2016 16:11 #126979
Čau Joomlisté,

testuju nový web a nějak nemůžu překonat problémy s Query. Nechce se načítat formulář dole na stránce www.ceskym-rajem.cz/nabidnete-bigadu-ces...ady-zjistete-5-kroku - pořád píše "Probíhá inicializace formuláře..." a nefunguje.

Z dokumentace od modulu Ajax perfect form jsem vyčetl, že to mohou způsobovat právě konfilkty s Query jednotlivých doplňků.

Tak jsem zkusil všechny povypínat + nainstalovat Perfect Joomla! 3 User Interface plugin, deaktivovat jiné Query i z něj, ale prd, stejně to nechodí.

Ufff, Query mi dává... Dokážete prosím někdo z kódu stránky vyčíst, co tam je za bord... nepořádek? view-source:http://www.ceskym-rajem.cz/nabidnete-bigadu-ceskym-rajem/131-jak-sestavit-skvelou-nabidku-brigady-zjistete-5-kroku

MaK.

--- -- -

12. kvě 2016 18:03 #126982
Odpověď od Houbák
Problém je zřejmě v tomto řádku
Code:
window.addEvent('load', function() { AddGoogleScript() });

Funkce addEvent() je totiž definovaná v JS knihovně Mootools, ale ta na stránce není načtená.

12. kvě 2016 18:13 - 12. kvě 2016 18:14 #126983
Odpověď od MaK.
Díky houbaku, mno jo, ale co s tím?

Ještě jedna info - postupnou dedukcí a mnohahodinovým vypínáním / zapínáním snad všeho jsem dospěl ke zjištění že:

A - Když je na stránce přes nabídku (menu) zobrazený 1 článek, modul se vůbec nezobrazí, třeba tady www.ceskym-rajem.cz/nabidnete-bigadu-ces...ady-zjistete-5-kroku

B - Když je na stránce přes nabídku (menu) zobrazené cokoliv jiného, například výpis blogu, jakákoliv jiná komponenta, tak se modul zobrazí v pohodě a funguje, například zde www.ceskym-rajem.cz/nabidnete-bigadu-ceskym-rajem

Může to mít souvislost s tím, co jsi uváděl? Napadá tě k tomu prosím něco?

MaK.

--- -- -

12. kvě 2016 18:33 #126984
Odpověď od Houbák
Jak už jsem psal, problém je v nenačtené knihovně Mootools, u zobrazení blogu se načítá, u zobrazení článku bohužel ne.

Ten JS kód se týká Google (načtení knihovny plusone.js), takže stačí tento plugin, či modul vypnout a mělo by být po problému. A nebo upravit šablonu ... netuším, kde přesně se ten kód načítá.

12. kvě 2016 19:00 #126985
Odpověď od MaK.
Děkuju, houbaku. Zkusil jsem postupně povypínat všechny moduly, beze změny. Zkusil jsem změnit šablonu, beze změny. Zkusil jsem povypínat pluginy (kromě systémových) i komponenty. Beze změny.

Napadá tě prosím, jak tento problém opravit? Jsi schopen a ochoten to za poplatek zmáknout?

MaK.

--- -- -

12. kvě 2016 20:18 #126986
Odpověď od Houbák
Pošli mi přístup do administrace a na ftp do PM nebo na mail a já na to mrknu.

Powered by Fórum