Call to undefined method JFormFieldRadio::getRende

Radek Tupý
22. dub 2016 23:23 - 22. dub 2016 23:23 #126741
Dobrý večer,
asi před 14 dny jsem na webu nechal upgradiovat Joomla z 3.4.8 na 3.5 . ihned po upgrade došlo v administraci k chybě
Fatal error: Call to undefined method JFormFieldRadio::getRenderer() in /web/htdocs1/elvispresleycz/home/www/libraries/joomla/form/fields/radio.php on line 53

Celá stránka je bez formátování, nekompletní a bez ovládacích tlačítek pro uložení ap. a hláška je dole.
Objevuje se pravděpodobně tam, kde je JCE editor (nedaří se mi je díky chybě odpojit)
O pár dní později byl upgrade na 3.5.1 - chyba stále. Dnes automaticý upgrade JCE ma 2.5.16. Odhlásil jsem a návrat zpět - chyba stále. Zkusil jsem pokusně dát místo daného skriptu z 2.4.8 - chybu začlo hlásit v jiném skriptu. Tak jsem to radši vrátil
Hostitelský server a databáze: Linux, PHP 5.6, DB MySQL 5.5
Hledal jsem na webu, ale buď hledám špatně nebo nic není...
Nemůžu do webu nic vkládat, Budu tedy vděčný za pomoc!!! Díky!!
(v příloze obtisk chyby)
Přílohy:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
23. dub 2016 01:18 #126744
Kde hostujete? Jakou šablonu v administraci používáte?

Zkuste to co popisuji zde: www.joomlaportal.cz/forum/71-joomla-3-0-...vrit?start=12#126725
Joomla se asi špatně aktualizovala, to musíte vyloučit...

I'm sorry, my responses are limited...you must ask the right questions.
Poděkovali: Radek Tupý

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek Tupý
23. dub 2016 08:55 #126746
Dobrý den,
nejprve velmi děkuji za pomoc a Váš čas! Já jsem mezitím zjistil, že prý to může souviset s komponentou RedCORE - a já ji skutečně mám, protože jsem sice instaloval čistou instalaci J 3.4., ale upgradoval jsem část dat z 1.5.6 pomocí této komponenty.!!Zkusil jsem postup, který je na oficielních stránkách popsán - prý upgrade z 3.4.8 na 3.5. nejde klasicky ... takže jsem rozbalil upgrade-balíček (na webu to nešlo, takže u sebe) a pomocí Total Commanderu (FTP) jsem to nahrál a dodělal postup, jaký tam psali (vyčištění cache ap.) Ale bohužel to nezabralo. Dokonce jsem hledal ve skriptech definici funkce :getRenderer() - našel jsem ji - ale nejspíš není použita.

Hostuji u Forpsi a nikdy nebyly problémy, šablonu v administraci mám tu defaultní, bez jiných úprav.
Ještě teď zkusím nějako odinstalovat RedCORE. A dám sem vědět. ještě jednou díky!

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek Tupý
23. dub 2016 09:12 - 23. dub 2016 09:14 #126747
VYŘEŠENO !!!
Situace:
Joomla byla před tím čístá instalace 3.4.8; ale instaloval jsem komponenty RecCORE a RedMIGRATOR pro částečný upgrade dat z verze J 1.5.7
Pak jsem teprve nahrával Joomla 3.5.0 a hned došlo k chybě. Nepomohl ani upgrade na 3.5.1

Oprava chyby:
1) Nejprve jsem nahrál (pomocí Total Commanderu) rozbalený balíček upgrade-joomly 3.5.1 - chyba byla stále
2) Odinstaloval jsem nejprve komponentu RedMIGRATOR a pak komponentu RedCORE (odinstalují se i příslušné moduly ap.) - v menu Rozšíření -> Spravovat -> Spravovat

Chyba se odstranila!! (dokonce, aniž bych se musel odhlašovat)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.