Nemáte oprávnění k přímému přístupu na stránky...

Jitka Šteffanová
22. led 2016 23:33 #125396
Zdravím všechny a prosím o radu, docela dlouho se s tím už trápím, diskuze prohledány - i zahraniční a nikde jsem nenašla tento stejný problém.
Chybová hláška: Nemáte oprávnění k přímému přístupu na stránky použít tento odkaz (#16), kdy číslo v závorce je v podstatě ID např. článku. Vím, objeví se, když je více uživatelů a jeden má třeba článek rozeditovaný, toto není ale ten případ. V systému je jeden uživatel a přesto to udělá. Všechny kontroly i čištění - nic nepomůže.

Dělá to ale jen na Českém hostingu, jejich podpora mi nepomohla. Mám tam jednak virtuální server a jeden můj klient tam má webhosting - dělá to na obou místech. Mám instalace Joomly i jinde (Wedos, Onebit, Activ24...), nikde jsem se s tímto nesetkala.

Hláška se objeví v administraci vždy když například kliknu na článek, uložím/zavřu, přejdu jinam, například administrace šablony/menu ... tam něco upravím, uložím/zavřu nebo i neupravím a vrátím se na ten předchozí článek = chybová hláška, to stejné i opačně, když se vrátím na předtím upravovanou šablonu = chybová hláška, pomůže odhlášení a přihlášení.

Dělá to jak na nové čisté instalaci, tak na obnoveném webu ze zálohy z jiného webhostingu (kde normálně funguje), na instalaci provedené přes "tlačítko" i na ruční instalaci. Zákaznická podpora tvrdí, že jim se chyba nepodařila nasimulovat.

Opravdu tento problém nikdo jiný nemá?
Zkusím přiložit video.

Děkuji

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
22. led 2016 23:48 - 22. led 2016 23:53 #125397
ve správci článků zaškrtněte ten článek a dejte "zkontrolovat".
Kdyby to nepomohlo zkuste ještě prohlížeč otevřít v anonymním okně a zkuste to tam.
Pokud ani jedno nepomůže, napište

ještě zkontrolujte - system - systémové informace - práva složek, zda je u všeho "lze měnit"

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jitka Šteffanová
23. led 2016 00:28 #125398
"kontroly" nepomůžou, v anonymním okně to taky dělá, udělá to i na menu nebo na šabloně, ne jen na článku, vždy když něco upravuji (i při uložení nebo jen zavření bez úpravy), jdu jinam a vrátím se k původní úpravě, tak už mě to tam nepustí.
V systémových informacích je u všeho "lze měnit", jen u "configuration.php" je na Českém hostingu "nelze měnit" a na wedosu "lze měnit", myslíte, že může toto být ten problém?
Dívám se, že video se asi připojit nepovedlo, dala jsem jej na dropbox: goo.gl/foP3pc
Ještě na ČH mám PHP v. 5.6.14-0+deb8u1, jinde jsou nižší verze PHP.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
23. led 2016 00:50 #125399
spíše by to configuration.PHP na to nemělo mít vliv, ale zkuste mu změnit oprávnění pomocí FTF.
Jaká je to verze joomly?
dělá to takto vždy u každého článku?

Máte v pořádku oprávnění a vlastnictví souborů a složek?

Zkuste v globální kontrole zkontrolovat tabulky databáze.
Po odhlášení a přihlášeni v administraci to udělá znovu?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jitka Šteffanová
25. led 2016 00:12 #125437
No, zkusila jsem změnit oprávnění configuration.php přes ftp, ale nepomohlo to.
Dělá to na všech verzích 3.xx, už jsem jich na ten virtuální server nainstalovala několik, dělá to ať je to nainstalované jako čistá instalace ručně, přes "rychlou instalaci" co nabízí webhosting, tak i obnovou ze zálohy z jiného hostingu, kde je web funkční.
Dělá to neustále, pomůže odhlášení a přihlášení, ale vždy jen na první klik na článek/menu/šablonu ... dělá to kdekoli, vždy po návratu na tu konkrétní položku. Není to vázané na konkrétní článek.
Mám několik instalací joomly na jiných webhostinzích a s tímto jsem se opravdu nikde jinde nepotkala. U ČH mám jednak virutální server a jednak tam má místní základka vlastní webhosting, dělá to na obou místech!
Člověk ze zákaznické podpory tvrdí, že jim se ten problém nepodařil navodit.
Samozřejmě jsem zkoušela i různé prohlížeče na svém počítači... už jsem zkusila asi všechno myslitelné, opravdu nevím, co s tím.
Není tu někdo, kdo má taky na www.ceskyhosting.cz webhosting nebo virtuální server?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
25. led 2016 13:14 - 25. led 2016 13:18 #125446
máte oprávnění superuser?
ten článek po otevření uložíte?
jaký používáte prohlížeč?
oprávnění configuration.php na to nemůže mít vliv.
Pořádejte hosting, aby Vám správně nastavil oprávnění a vlastnictví složek a souborů.

zkuste si to nainstalovat na localhost na svoje PC, zda to také dělá.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jitka Šteffanová
25. led 2016 14:46 #125449
Nezlobte se na mě, ale četl jste, co jsem psala výše? Stejný web (obnovený ze zálohy) to na jiném webhostingu nedělá, dělá to i úplně čistá nová instalace, opravdu to dělá jen na Českém hostingu. Oprávnění mám, článek můžu uložit i jen zavřít .... všechny varianty ... koukněte i na přiložené video - dávala jsem na dropbox. S hostingem jsem to řešila, prohlížeče prostřídala, zkušenosti s joomlou mám myslím docela velké (asi 7-8 let), ale s tímto jsem se jinde nesetkala.
Jediné co mám jinde jiné, tak je asi verze PHP,kdy mívám nižší verze 5.4,5.5, tady je 5.6.

Děkuji

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
25. led 2016 14:56 #125451
četl jsem, ale raději se na některé věci zeptám dvakrát.
I na video jsem se díval.
Matně jsi vzpomínám, že jsem se kdysi s něčím podobným setkal a to souviselo s oprávněními a vlastnictvím složek.
Když web akeebou obnovíte na jiném místě, nastaví se jinak i oprávnění.
verze PHP by na to neměla mít vliv.
Možná může být problém s cache na serveru.

a asi bombardovat hosting

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jitka Šteffanová
25. led 2016 15:31 #125452
Děkuji moc, právěže na podpoře mi neporadili, že s joomlou nemají zkušenosti (přitom se chlubí připraveností na joomlu), kdyby mi to dělalo u nich na jednom účtu, ale místní ZŠ tam má už dlouho webhosting a tam to dělá, já jsem si na podzim u nich zaplatila virtuální server a dělá to taky, jak jsem psala, zkoušela jsem i různé typy instalací - na tlačítko, čistá ruční instalace, obnouvou ze zálohy .... dokonce mám (tedy z jiných důvodů) v prosinci přeinstalovaný počítač, takže ani s tím to nemůže souviset, vyzkoušela jsem různé prohlížeče, holt od nich budu muset asi zas odejít, ale vyhodila jsem peníze za ten virtuální server ... doufala jsem, že tu bude někdo, kdo u nich je a že poradí :)
Projdu večer ještě ta oprávnění...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Ernst
25. led 2016 16:22 - 25. led 2016 16:23 #125456
pokud u nich podpora není schopná poradit a je to vlastnost hostingu, je čas uvažovat o změně hostingu.
Nechci nikoho protěžovat, ale u hodně webů používám www.levne-domeny.cz/ a jsem s nimi spokojen

PS oprávnění a vlastnictví souborů vám musí nastavit hosting, přes FTP nastavíte jen část
Poděkovali: Jitka Šteffanová

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
25. led 2016 17:22 - 25. led 2016 17:23 #125457
Co z dávných dob pamatuji tak na ČH je problém s vlastnictvím.
Oprávnění i vlastnictví složek a souborů by mělo být v pořádku pokud provedete:
  • čistou instalaci po nahráním celého instalačního ZIP a jeho rozbalení až na serveru
  • obnovení ze zálohy po nahráním celého balíčku zálohy JPA nebo ZIP a jeho rozbalení až na serveru pomocí kickstart.php
  • s velkou pravděpodobností i instantní instalaci Joomly poskytovanou hostingem
Samozřejmě po těchto nahráních je potřeba se už přes FTP v souborech "nerejpat" a použít třeba Phoca Commander přímo v Joomle.

Přesto si myslím, že problém bude někde jinde. Buransky řečeno: někde stále visí informace, že se článek edituje, i když tomu tak není..., že by session, cookies, cache? Třeba se tu najde někdo, kdo tomu rozumí.

I'm sorry, my responses are limited...you must ask the right questions.
Poděkovali: Jitka Šteffanová

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Pavel
25. led 2016 17:42 #125458
Dobrý den,
na českém hostingu mám též virtuální server, a tyto problémy co popisujete vidím poprvé, nikdy se mi nic takového zatím nestalo a to dělám jak čisté instalace, tak instaluji ze zálohy. Jediné co bylo, tak jedna komponenta mi nechtěla ukládat své nastavení, což se dělo pouze při práci přes prohlížeč FB. To jsem pak po dlouhém bádání vyřešil úpravou souboru .htaccess.
Poděkovali: Jitka Šteffanová

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
25. led 2016 20:18 #125469
Pokud si vzpomínám, na Českém Hostingu jsem se s tím také setkal, bylo to ale jen v kombinaci s použitím IE. Zkuste jiný prohlížeč.
Poděkovali: Jitka Šteffanová

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jitka Šteffanová
25. led 2016 22:17 #125471
Děkuji moc všem, budu zkoušet dál, mám Win10 a zatím v chrome,edge a exploreru to dělá pořád, vím, že na podzim to dělalo i ve firefoxu, ale ten teď nemám nainstalovaný, protože jsem komplet přeinstalovávala systém (výměna disku).
Případně jaká úprava v .htaccess pomohla?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jitka Šteffanová
25. led 2016 22:25 #125472
Takže poslední verze FireFox a už 5 minut to jede :)
Děkuji moc všem!

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.