Phoca - chyby po kliknutí pod nabídkou komponenta

Jan Řehoř
08. led 2016 21:47 #125154
Dobrý večer,
nedaří se mi vygůglit co mohu udělat s tímto: Nemohu se dostat do komponent od Phoca.
Mám Joomla 3.4.8
Když kliknu v nabídce komponenta na cokoliv od Phoca vyhodí mi to tuto chybu.

Fatal error: Class PhocadownloadCpController cannot extend from interface JController in /data/web/virtuals/clients/client1/web1304/web/administrator/components/com_phocadownload/controller.php on line 45

Fatal error: Class PhocaGalleryCpController cannot extend from interface JController in /data/web/virtuals/clients/client1/web1304/web/administrator/components/com_phocagallery/controller.php on line 46

Děkuji moc za pomoc a trpělivost se mnou

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
08. led 2016 22:01 #125155
Jedná se o nové instalace? A instalované verze Phoca komponent?
www.phoca.cz/forum/viewtopic.php?f=31&t=26033

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
08. led 2016 22:42 #125156
Tipl bych, že jste buď právě migroval z Joomla 2.5 a neaktualizoval Phoca Download, nebo nainstaloval Phoca Download určený pro Joomla 2.5 místo pro Joomla 3.x

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jan Řehoř
08. led 2016 22:57 #125157
Dobrý den, děkuji Vám za odpověď.
Jedná se o aktualizaci. Nejedná se o migraci. Měl jsem Joomla 3.4.něco (asi 1) a udělal jsem upgrade na 3.4.8
Potom mi to nabídlo ještě nějaké aktualizace komponent a tím vznikla asi ta chyba.

Sice jsem si při aktualiozaci Jomly udělal zálohu, ale když jsem zjistil, že joomla funguje, tak jsem ji smazal (neb mě hosting za to nemá rád, když tam nechávám zálohy webu, které mají 4 a více GB).

Phoca Galery je teď verze 3.2.8
Phoca stahování je teď verze 2.1.9
Děkuji moc

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
08. led 2016 23:22 - 08. led 2016 23:39 #125158
No a v tom to je, Phoca Download máte mít 3.1.0 a ne 2.1.9 a Phoca Gallery 4.2.2 a ne 3.2.8.

A k těm zálohám - zálohujte samotný web bez obrázků a souborů ke stažení, a budete mít zálohy tak malé, že hostingu určitě vadit nebudou. Soubory ke stažení funkčnost web neovlivní, tak když nebudou v záloze, ničemu to nevadí.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
09. led 2016 00:45 - 09. led 2016 01:40 #125159
Také si nainstalujte aktuální češtiny (pro Joomla 3.x):

www.bongovo.cz/ke-stazeni/category/14-phoca-gallery
www.bongovo.cz/ke-stazeni/category/16-phoca-download

Dle názvosloví, které používáte, tam máte také něco historického.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jan Řehoř
10. led 2016 16:51 #125171
Děkuji za pomoc, funguje

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.