JCE editor - chyba s výpisem češtiny s diakritikou

Jiří Karger
26. dub 2015 19:57 - 26. dub 2015 20:05 #121635
Hezký den.
Mám následující problém s JCE editorem - poslední verze (možná ale dělalo i dříve) na Joomla 3.4.1
V databázi mám články s kódováním UTF8, tedy správně s češtinou, přes TinyMCE editor je i v Source code variantě vidím správně - tedy např:
<p>Omlouváme se, ale tento článeček bude doplněn později. Děkujeme za pochopení!</p>
Pokud se přepnu do JCE editoru, v klasickém náhledu vidím vše správně, ale v Toggle Editoru (tedy při přepnutí do klasického zobrazení kódu) vidím: viz příloha.

Jakoby JCE v Toogle náhledu nedokázal interpretovat některé české znaky s diakritikou?
Nevíte někdo prosím co s tím, jak to napravit?
Monti
Přílohy:

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
26. dub 2015 21:45 #121636
Podívejte se do nastavení JCE - Entity Encoding nastavte na UTF-8, pokud nemáte.
Poděkovali: Jiří Karger

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jiří Karger
27. dub 2015 06:54 #121640
Bezva, moc děkuji za nasměrování. :)
UTF-8 tam sice bylo nastaveno, ale stačilo přepnout do jiné volby např. Jméno a dát Uložit a následně změnit zpátky - vrátit na UTF-8 a čeština již funguje správně.
Díky za radu i pomoc.
Stalo se mi to po migraci na vyšší řadu PHP a MySQL na hostingu Joomly a obnově ze zálohy Akeeba Backup - pokud by někdy někdo řešil něco podobného.
Monti

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.