Propojení Virtuemart 3 a Pohoda

beny.rfg
23. lis 2014 19:44 #119018
Zdravím komunitu,

prosím o radu ohledně propojení Virtuemartu s účetním systémem Pohoda. Vím o doplňcích od Artio nebo od Firmadat, ale tyto ještě nepodporují J3 a VM3. Budeme stavět novou verzi e-shopu kde je potřeba toto propojení, ale zdá se mi nesmyslné a omezující kvůli tomu dnes stavět web na J2.5 a VM2.
Má někdo zkušenosti s jinými propojeními např. na jiné účetní systémy, co by šlo třeba s nějakou drobnou modifikací použít na Pohodu? Zřejmě to bude na podobném principu exportu do XML. Případně napadá někoho jakékoliv jiné řešení?

Děkuji

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
23. lis 2014 22:35 - 24. lis 2014 11:43 #119022
Informace o nové verzi Virtuemart je na světě 4 dny a vy už chcete aby ji všichni výrobci rozšíření podporovali? Poptejte přímo autory propojení a podle toho naplánujte výstavbu nového shopu.

EDIT Zkuste mrknout na článek o Virtuemart 3 www.joomlaportal.cz/clanky-virtuemart/no...-virtuemart-3-je-zde

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od beny.rfg
24. lis 2014 23:03 #119037
Vycházím z toho, že testovací verze už nějaký ten pátek na světě je, a v případě jiných rozšíření už má spousta výrobců také hotovo...
Mnou zmíněné výrobce jsem kontaktoval a vypadá to zhruba na polovinu příštího roku, s vývojem ještě nezačali.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
25. lis 2014 10:36 #119042
Já vám rozumím, že chcete rovnou to nové, ale je opravdu ještě brzo.

Dokonce autory doporučená sestava je J2.5 + VM3... a jsou i další mouchy. Viz zdejší diskuze: www.joomlaportal.cz/forum/71-joomla-3-0-...oomla-3?limitstart=0

Pokud to není nutné, prostě se vyplatí počkat.
V opačném případě bych volil (pro tuto situaci) J2.5 + VM2 + doplňky a jakmile bude vše potřebné k dispozici pro nové verze není upgrade problém. Joomlu ani WM není třeba na vyšší verze nijak složitě migrovat, pjednoduše se zaktualizují.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od beny.rfg
01. pro 2014 19:39 #119174
Díky za radu... rozumím tomu dobře, že při upgrade z J2.5 a VM2 na J3 a VM3 nebude potřeba znovu stavět šablonu, nebo kupovat novou? Bude si to spolu rozumět? Vzpomínám na poměrně složitý proces migrace z 1.5 na 2.5, takže pokud se v tomto ohledu něco změnilo, je to super...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
01. pro 2014 20:36 #119176
Přechod z Joomly 1.5 byl migrace - měnila se kompletně databázová struktura.
Přechod z Joomly 2.5 je aktualizace, stáhnete a nainstalujete stejně jako jinou aktualizaci.
Úplně bezbolestné to ale není, je potřeba dodržet určité postupy, je možné, že Vaše šablona bude potřebovat upravit (používá funkce, které v 3.x už nejsou) apod.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Martin Bartůněk |anBLOK|
03. led 2015 10:33 - 03. led 2015 10:41 #119498
Promiňte, ale vzhledem k tomu, že J 2.5 na konci roku ztratila podporu, příspěvek podivující se necelé dva měsíce před touto situací, na tím, že kdosi „chce vše nové hned“ mi nepřijde od zkušeného jomlisty jako příliš korektní… Doplňky a rozšíření firem, které se tímto komerčně zabývají (a mají své klienty, kteří dosud za jejich produkty platili) by měly tak vážnou skutečnost, jako ukončení podpory základního systému a přechod na nový, vyšší, účinně reflektovat. Jestliže toto někdo předpokládá automaticky, chybným postojem to jistě není.

… i když chápu, že spíše komentujete nepříjemnou realitu… :)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
03. led 2015 15:51 #119503
No on je problém spíš s VM, než s Joomlou. VM verze 3 by sice měl na Joomla 3 fungovat, ale doporučená konfigurace je stále VM3 na Joomla 2.5. Podobná situace byla při ukončení Joomly 1.5, VM 2 byl uveřejněn tuším až celekm dlouho po zveřejnění Joomly 2.5, pro Joomlu 1.6 a 1.7 byl jen v betaverzích.

Takže vývojáři rozšíření pro VM se spíš drží verzí VM než Joomly samotné...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.