Instalace Joomla 3.2 přes Server2Go

Jan
16. led 2014 09:46 #113878
Zdravím,
jsem úplný začatečník. Může mi prosím někdo poradit, jak odstranit problém s Magic Quotes GPC vypnuto pro instalaci Joomly na Server2Go? Zkoušel jsem dle návodu Internetu přidat do instalačního adresáře Joomla soubor php.ini s obsahem
magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off
ale to nestačilo
Ještě se píše, že je potřeba přidat do souboru .htaccess následující kód:
<IfModule mod_suphp.c>
suPHP_ConfigPath /home/myusername/public_html/yourJ3folder
<Files php.ini>
order allow,deny
deny from all
</Files>
</IfModule>
Nerozumím, jakými adresáři mám dle návodu nahradit "myusername" a "yourJ3folder".
Nebo mám postupovat nějak jinak?
Díky za odpověď

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od karel
17. led 2014 00:32 - 17. led 2014 00:34 #113897
Chcete-li/potřebujete-li řešit celou záležitost na Server2Go (i přes jeho poněkud "starší" vydání, i krkolomnost tohoto řešení):
- najděte soubor php.ini v _originální_ distribuci Server2Go (server2go/server/config_tpl/php.ini), a tam změňte, co potřebujete:
; Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc = Off



- cestu (absolutní, tj od začátku) máte uvést až ke složce s Joomlou. Pokud máte nahraný, rozbalený obsah instalačního balíku Joomly do "výchozí složky" server2go (třeba ve vašich dokumentech), tak absolutní cesta bude (například):
C:/Documents and Settings/bartonicek/Dokumenty/server2go/htdocs/

Cesty (mj i všechny "důležité" informace o fungujícím PHP ), najdete v phpinfo. Odkaz na informace "phpinfo" máte v pravé části výchozí stránky, po spuštění Server2Go.

Pro testování na localhostu doporučují použít XAMPP / WAMP / LAMP / MAMP / ...( it-slovnik.cz/pojem/xampp )

Znáte-li řešení, sdělte ho - pomůžete ostatním při řešení stejného problému, i případný "rádce" bude vědět, poradil-li správně nebo špatně.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jan
17. led 2014 10:29 #113905
Děkuji za odpověď. Dal jsem na vaši radu a zkoušel jsem několikrát nainstalovat Joomlu přes XAMP i WAMP. Postupoval jsem u obou programů podle online návodů a objevil se při instalaci Joomly stejný problém u obou programů.
Vše jde dobře podle návodu až do bodu 3 Souhrn. Pokud spustím Joomlu instalovat, vždy se instalace zasekne u části Tvorba databázových tabulek.
Hledal jsem možnou příčinu na webu a zkusil:
1) v souboru php.ini jsem změnil max execution time na 3000
2) odinstaloval Skype
3) vypnul Firewall
XAMP Control Panel v3.2.1. hlásí, že vše běží bez problému. Používám Windows 8. Tento problém se vyskytuje u více uživatelů, ale nepomohly mi žádné tipy, které jsem našel na webu. Nevíte, co by mohlo problém vyřešit?
Díky za odpověď

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jan
17. led 2014 10:40 #113907
Problém vyřešen :)
je potřeba v instalačním souboru Joomla.sql (installation\sql\mysql) nahradit
původní "ENGINE=InnoDB" novým "ENGINE=MyIsam". Pak jde instalace bez problémů.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.