Wamp a používání verze PHP

Jan Kedvis
28. srp 2013 15:39 #110410
Ahoj, mám ještě takový jeden problém. Používám Wamp (poslední verzi), který asi většina z vás zná, ale potřeboval bych na této nejnovější verzi Wampu, která jede na PHP 5.4.14 rozjet i starší stránky. Vím, že stránek tvůrců tohoto programu mohu státnout i starší verze PHP a MySQL (a snadno doinstalovat), ale nevím které to jsou a v jakém pořadí je mám nainstalovat. Např. pro mou verzi PHP 5.3.6-pl1-gentoo nikde nic nenacházím a nebo nevím, které verze postačí (odkaz na stránky je zde a na stránkách je to úplně dole žluté tlačítko "adddons PHP")? Také nevím, zda musím stáhnout i starší Apache (web server) a který? Přišel jsem na všechno tak, že moje starší stránky (zalohované Akeeba Backup) nešly rozbalit do nového Wampu. Při instalaci zálohy přes kickstart.php vše probíhá normálně a až po kliknutí na utomatické odstranění složky se objeví prázné stránky s textem " Chyba kódování obsahu. Stránka, kterou se snažíte načíst, nemůže být zobrazena, jelikož server používá neplatný či nepodporovaný způsob komprimace dat.

Mé informace o systému (mého staršího webu):

HP built zapnuto Linux 2.6.32 #1 SMP Thu Nov 1 14:38:46 CET 2012 i686
Verze databáze 5.1.56
Porovnání databáze utf8_general_ci
Verze PHP 5.3.6-pl1-gentoo
Webový server Apache/2.2.17
Rozhraní Webový server na PHP apache2handler
Verze Joomla! Joomla! 2.5.6 Stable [ Ember ] 19-June-2012 14:00 GMT
Verze platformy Joomla! Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

Děkuji za rady.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
28. srp 2013 18:44 #110415
Tak si nainstalujte starší verzi Wamp s PHP jaké vám vyhovuje.

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jan Kedvis
28. srp 2013 19:36 - 28. srp 2013 19:37 #110418
To už jsem zkoušel a hádalo se to. Dokonce jsem to kombinoval i s Xampp. Ale mělo by to jít jednodušeji kdyby mi někdo řekl jaké verze PHP a MySQL (ppř. i Apache) mám z těchto stránek stáhnout. Jediné na co jsem narazil je toto zde a je vidět, že by to mělo nějak jít (ty verze se dají přepínat). Ale jaké verze a jsou tam vůbec ty správné? Odkazy v tomto článku nesměřuji na místo kde by byly soubory pro PHP 3 apod. Myslím tím tu moji výše uvedenou verzi PHP a další soubory. Nevím, zda postačí jen nějaký soubor z této řady (v mém případě PHP 3x) a nebo se musí jednat o instalaci přesných konkrétních verzí. Tedy nevím co stáhnout (rúzné soubory), aby to vše fungovalo jako kdybych si nainstaloval Wamp s PHP 3, tak jak je i na těch stránkách uveden. Děkuji za radu.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
28. srp 2013 20:07 - 28. srp 2013 20:07 #110421
Osobně používám XAMPP, ale na stránkách WAMPP máte ke stažení instalace různých konfigurací. V čem tedy vidíte ten problém nefunkční instalaci odinstalovat a nainstalovat co je vám libo?

www.wampserver.com/en/

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jan Kedvis
28. srp 2013 20:22 #110423
Podle toho článku (doinstalace starších verzí PHP apod.), na který jsem dal odkaz v předchozím článku, bych rád používal jeden Wamp s možností přepínat na různé druhy PHP apod. Např. To co jsem kdysi vytvořil v PHP 3 mi teď nepoběží na Wampu s PHP4 a když si například stáhnu zálohu z nějakého staršího webu, tak ji nemohu spustit, natož dál upravovat v novém Wampu. Podle mě je logické, když chci v jednom programu přepínat podle potřeby (což by podle toto článku mělo jít). Přece pokaždé nebudu instalovat a odinstalovávat různé verze Wampu. Děkuji za rady.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
28. srp 2013 20:44 #110425
Dole na stránce jsou addons, dokonce tam máte tabulky co s čím můžete kombinovat. Jen myslím, že některý pravěk by se měl nechat zahrabaný pro archeology...

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Jan Kedvis
28. srp 2013 21:21 - 28. srp 2013 21:27 #110428
Znamená to, že by mi to mělo běžet, když mám verzi verze PHP 5.3.6-pl1-gentoo a stáhnu např. verzi PHP 5.3.1 (protože verze PHP 5.3.6-pl1-gentoo tam není) a webový server Apache 2.2.14 (protože Apache/2.2.17 tam není) a jakékoliv MySql5 x, tak to bude fungovat?

Starší konfigurace Wampu:

Wampserver (64 bits & PHP 5.3) 2.2E

Apache 2.2.22 – Mysql 5.5.24 – PHP 5.3.13 XDebug 2.1.2 XDC 1.5 PhpMyadmin 3.4.10.1 SQLBuddy 1.3.3 webGrind 1.0



Díky za radu. Trochu se v tom ztrácím a hlavně nevím, zda musím pro výše uvedenou potřebu stahovat i starší verzi Apache? Jak může Apache 2.2.22 fungovat s PHP 5.3.13, když tam v té tabulce jsou křížky u verze 5.4 a nebo PHP 5 < 5.2.0 ? Nějak nerozumím tomu číslování a tomu co obsahuje ta starší konfigurace Wampu. Proro se ptám na to má co vlastně stáhnout?

Jinak souhlas, ale co nadělám s tím, když se vše tak rychle mění :-) Děkuji.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.