Joomla 3.0 - update to 3.1 - problém

sender
25. dub 2013 09:50 #106920
Dobrý den,

při pokusu o update joomly se mi při pokusu o znovunačtení stránek objeví tato chyba jak při pokusu o načtení backendu tak stránek. Nesetkal se s tím někdo.

Parse error: syntax error, unexpected $end, expecting T_VARIABLE or T_DOLLAR_OPEN_CURLY_BRACES or T_CURLY_OPEN in /data/web/virtuals/40519/virtual/www/libraries/joomla/document/html/renderer/message.php on line 108

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od ghost
25. dub 2013 10:03 #106923

Joomla! pro každého

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od sender
25. dub 2013 12:32 #106931
Vyřešeno, aktualizováno, vyzkoušeno.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Karel Šedivý
27. dub 2013 16:12 #107015
Mohl by někdo ve zkratce a laicky vypsat changelog, teda proč se vyplatí upgrade na takové vyšší verze?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
27. dub 2013 16:35 - 27. dub 2013 16:46 #107017
Že byste si přečetl odkazovaný článek o pár příspěvků výše? Nebo čtěte přímo na www.joomla.org/

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od sender
27. dub 2013 21:21 #107022
To ghost:

Joomla 3.1 is the newest version recommended for most new installs. It includes the latest and greatest features of Joomla and mobile/responsive support.

Víte o tomto upozornění?

www.joomla.org/download.html

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
27. dub 2013 22:21 #107024
To sender:

a o pár řádek níže

When starting a new site, please plan ahead and check to make sure that any extensions (including templates) that you plan to use are Joomla 3 compatible. If not, then Joomla 2.5 still provides you a well supported option in the meantime.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od sender
28. dub 2013 08:24 #107031
To Cony:

Já mám všechny použitá rozšíření co jsem potřeboval kompatibilní :) .

Tak si myslím že by tady mohl někdo napsat článek že Joomla 3 po ověření kompatibility komponent je doporučená pro nové weby. Teď to tady vyznívá jakože Joomla 3 je jen pro nadšence.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od prontik
28. dub 2013 08:57 #107034

sender napsal: Tak si myslím že by tady mohl někdo napsat článek že Joomla 3 po ověření kompatibility komponent je doporučená pro nové weby. Teď to tady vyznívá jakože Joomla 3 je jen pro nadšence.

Tak sednete a napiste ho ten clanek, nikdo vam v tom nebrani. By me zajimalo to tam bude napsano v duvodech ''Proc nasazovat J!3 uz nyni''.

Co me se tyce, ja si pockam na LTS verzi. Nevim proc vsichni hned blazni. Zatim me nanapada duvod proc nasazovat STS verzi, kdy muzu pri dalsich postupnych aktualizacich cekat tu a tam nejaky problem (viz 2.5.9 na 2.5.10, apod.). Prechod z 2.5 na 3./3.5 bude jednim kliknutim, navic komponenty, ktere jsou delane pro 2.5 jsou v drtive vetsine i pro 3,

Tudiz v cem tkvi ta vyhoda jit už ted do STS verze???

Joomla je jako puzzle. Stačí vědět jak ty dílky k sobě poskládat.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od hrackar
28. dub 2013 09:01 #107035
To: Sender

Predem pisi, ze reaguji z S3 a tudiz nejsou reseny hacky apod. Neda mi to musim na Vas reagovat. Ano mate pravdu, ze z pohledu klikace, ktery si vezme CMS Joomla! a jde si poskladat jednoduchy web u ktereho neni predpoklad budouciho rozvoje planovan, ze si ho postavi na z meho pohledu nestabilni vetvy Joomla! systemu a do sveta cile troubi jak Joomla! 3.0 je dokonalej system, ktery je plne doporucen na nasezeni pro ostry provoz. A ted ....

Pane kdyby jste mozna programoval a vytvarel rozsireni pro CMS Joomla! nebo se jen vice zajimal o Joomla! API, ktere tvori Joomlu Joomlou vedel by jste, ze ted je malicko v tomto systemu hokej nebot sice vyvojovy tym tvrdi, ze v Joomla! 3.5 a dale budou aktivni obe dve Joomla! API respektive dve vetve kdy budete moct psat po novu ci po staru tak jak komu to vyhovuje, ale vzhledem k tomu, ze se tato informace meni jako kdyz houby rostou po desti tak urcite je idealni pouzit STS verzi systemu u ktereho se vse muze doslova ze na den menit nez radeji pouzit stabilni LTS verzi u ktere vim na cem jsem a to se nebavim o rozsirenich systemu.

Kazdopadne jste odhadl spravne, ze Joomla 3.0 je urcena spise pro vyvojare, testery a nadsence. Rozhodne neni tento system urcen pro ostre nasazeni pro bezny provoz a uz vubec ne pro vetsi projekty coz u Vas samozrejme nemohu posoudit. Nikdy tomu tak nebylo a nikdy nebude at se budete utesovat jak chcete.

A pro Vasi informaci bych jeste dodal jednu vec. STS verze jsou nahledy LTS verzi co funkci a zavadeni zmen v jadre, ale to jste jiste vycet. Na delsi cas se opet loucim.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od prontik
28. dub 2013 09:10 #107036
to hrackar

Lip bych to nenapsal... Kde to muzu podepsat.

Joomla je jako puzzle. Stačí vědět jak ty dílky k sobě poskládat.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od hrackar
28. dub 2013 09:17 - 28. dub 2013 09:18 #107038
To: prontik

To uz jsi udelal :-)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od sender
28. dub 2013 09:58 #107043
Každý si to může při zakládání webu přebrat sám.

Pro většinu nových stránek je oficiálně doporučena Joomla 3.

docs.joomla.org/Joomla_3_FAQ#I.27m_build...ite_or_a_3.x_site.3F

magazine.joomla.org/issues/issue-nov-201...joomla25-vs-joomla30

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od hrackar
28. dub 2013 10:39 - 28. dub 2013 10:40 #107046
To: Sender

Nebudu se s Vámi přít neboť toto by nemělo již žádný význam. Řeknu to otevřeně a bez příkras. Pro člověka, který chce riskovat a mít problémy u projektu, který bude pro něj životně důležitý a nebo nutný pro jeho podnikání, případně pokud bude potřebovat rozjet například e-shop u kterého počítá s vysokým nárůstem klientů a je hazardér nechť využije Joomla! 3.x a člověk nebo firma, která potřebuje stabilní, relativně bezpečné a bezproblémové řešení sáhne po Joomla! 2.5.x z několika důvodů, které jsem uvedl nahoře. Viz například problémy s Joomla! API, které pokud by se vývojáři rozhodli od například Joomla! 4.5 definitivně odebrat bude nutné v mnoha případech všechna rozšíření značně přepisovat. Kdo ví o čem mluvím mi dá za pravdu, že to je maličko horor i když snad dle článku na developer.joomla.org/cms/roadmap.html část 2 (Roll back MVC Legacy Classes) to už nevypadá tak žhavě.

Každopádně ani vývojový tým Joomla! v podstatě neví co chce neboť článek zde developer.joomla.org/news/76-the-new-joomla-framework.html také o něčem vypovídá viz "Changing the Name to the Joomla Framework" část přeložena zde www.website21.cz/novy-joomla-framework

Pokud si totiž budete chtít nechat vytvářet nějaké rozšíření řekněme na zakázku tak Vás bude většina firem hned beztak hnát do Joomla! 2.5 z výše uvedeného důvodu. Za další psát pro Joomla! 3.0 není problém neboť je pravda, že je potřeba provést pár kosmetických úprav v kódu pro spuštění (funkčnost), ale je zde například problém s GUI rozšíření, která jsou vázána na běžné šablony administrace neboť například šablona bluestrok již v nové verzi Joomla! není neboť nám zde páni programátoři z Joomla! pracujicí pro různé nadnárodní společnosti dostali skvělý Twitter Bootstrap i tam kde není potřeba (můj osobní názor).

Takže pokud to rozšíření nemá své vlastní stylování pro admin tak je to noční můra vývojářů, ale to nechme být neboť toto není Vaše parketa a nemá smysl řešit pro Vás jemné rozdíly. Není to podstatné pro tuto diskuzi. Používejte STS verze, budujte svůj pracně vytvořený web na STS verzích a věnujte do toho mraky času. Když se Vám to potom sesype tak hlavně nebrečte, že jste systém rozchodil na STS verzi systému, která Vám záhadně přestala jít, protože je to STS verze a přeci dobré rady od lidí (Ghost, Bong, Prontik aj.), kteří Vám radily nejít do STS verze, ale do LTS verze jsou téměř choří na mysli.

Jsou tu určití lidé, kteří s Joomla! pracují již mnoho let a mají za sebou mnoho projektů a určitě ví co to je strávit nad nějakým projektem řádově stovky hodin o které můžete přijít když pak kvůli nějaké zbrklosti to padne. Tím netvrdím, že to zrovna musí být jejich případ.

Osobně s Joomla! pracuji již od verze Joomla! 1.0, která byla více Mambo než Joomla! a rozhodně mohu potvrdit jedno, že v životě bych nešel do STS verze krom testování nových svých rozšíření nebo pro účely testování co nového nám Joomla! přinese do LTS verze. Víte, ono budovat web a pokud svůj tak je to běh na dlouhou trať na které můžete nasekat mnoho chyb a dočkat se mnoha překvapení, která nebývají mnohdy moc příjemná.

Takže nechte naše rady ladem a již neřešte zda je lepší používat aktivně LTS nebo STS verzi neboť ona magická slůvka STS a LTS pro Vás nic neznamenají. Pokud jsem maličko nepříjemný tak se předem omlouvám, ale nemám ve zvyku tu lidem vysvětlovat něco co beztak slyšet nechtějí. Obecně se to mu říká ztráta času.
Poděkovali: Bart

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.