problém při migraci na joomla 3.0

protektor
05. úno 2013 12:19 - 05. úno 2013 12:19 #103507
Zdravím, zkoušel jsem převést joomlu na verzi 3.0. Bohužel mi spadla a hlásí mi chybu. Neporadí někdo jak postupovat při obnově? Díky za radu.
Před migrací jsem si joomlu zálohoval. Toto mi to hlásí: Fatal error: Call to undefined method JRegistry::getValue() in /data/web/virtuals/25743/virtual/www/components/com_jcomments/libraries/joomlatune/joomla/jversion.php on line 35

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
05. úno 2013 12:21 #103508
A proč na 3.0 migrujete? Hlasí Vám to, že máte komponentu jComments, která zřejmě ještě 3.0 nepodporuje.
A jak jste zálohoval?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od protektor
05. úno 2013 12:25 #103510
Záloha proběhla automaticky před instalací. Pomocí Akeeba Backup. Bohužel se nemůžu dostat ani na administrátorské rozhraní

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
05. úno 2013 13:17 #103512
Pak máte někde na serveru tu zálohu, např. tady máte video návod jak se zálohou pracovat.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od karel
05. úno 2013 13:30 #103514
Sice Vám varování, o "šetrném zacházení" se soubory zálohy asi nebude stačit (stejně tak, jako nestačí varování, že Joomla stávajících verzí 3.0.x je určena pro vývojáře), ale

soubor zálohy (archív *.jpa nebo *.jps) je většinou ve složce ~/administrator/components/com_akeeba/backup/

Znáte-li řešení, sdělte ho - pomůžete ostatním při řešení stejného problému, i případný "rádce" bude vědět, poradil-li správně nebo špatně.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bart
05. úno 2013 13:44 - 05. úno 2013 14:03 #103516
Už to tu bylo několikrát řečeno, ale nevadí, přidám se také :). Joomla 3.0, 3.1 a 3.2 jsou určeny pro cituji: "nadšence a vývojáře (Joomly)". Slouží vlastně k otestování funkčnosti nové zaváděných funkcí, mezi větší masou lidí.
Stejně jako zde ostatní, tak ani já nedoporučuji nějak moc nasazovat Joomla 3.0. Důvod je jasný, jsou zde nové funkce, které nejsou úplně odladěny, není zatím tolik rozšíření pro tento systém a ani systém samotný není moc rozšířený (mezi uživateli), ale především mnoho vývojářů tuto verzi ignoruje.
Navíc pokud mohu mít názor na Joomla 3.0 tak není zrovna tak úchvatná, aby musela být nutně nasazena. 99,9% věcí obsahuje Joomla 2.5.7 a novější také.

Jediný největší rozdíl mezi těmito verzemi je v bootstrapu, ale ten už není nijak uchvacující, protože ho má vlastně každý a "především stejný". Takže to není podle mne až tak in. Typografie, stylování atp. jsou vesměs skoro úplně stejné, což podle mého názoru není tak hezké, není zde žádná individualizace :(.
Pokud potřebuje responsivní administraci, existují i lepší šablony, než ta co je v Joomla 3.0. Já se v ní po půl roce nemohu moc zorientovat, administrace je podle mého chudá. Chybí zde nějaké orientační ikonky :D.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od karel
05. úno 2013 13:55 #103519
OT: Barte, hodilo by se "přípíchnout" takový příspěvek (o nevhodnosti ostrého nasazení) do každé(?) kategorie o J3.0, a my, ostatní, bychom pak mohli takového tazatele (z dotazu kterého je zřejmé, že vývojář není) pár dní ignorovat, aby stihl se "vývojářem" "stát" a podobné dotazy nepokládal.

Znáte-li řešení, sdělte ho - pomůžete ostatním při řešení stejného problému, i případný "rádce" bude vědět, poradil-li správně nebo špatně.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od protektor
05. úno 2013 14:05 #103522
Díky všem za komenty. Je to moje chyba. joomla na mě vybafla, že existuje nová verze. Tak jsem ji chtěl nainstalovat. Poučení pro příště: "nešťourat se v tom pokud to funguje" Aspoň mám o zábavu na dnešní večer postaráno. No a při nejhorším snad budou mít zálohy na webhostingu.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
05. úno 2013 14:11 #103524
OT. To není špatný nápad s tím ignorováním dotazů na J3.0...

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bart
05. úno 2013 14:14 - 05. úno 2013 14:19 #103525

protektor napsal: Díky všem za komenty. Je to moje chyba. joomla na mě vybafla, že existuje nová verze. Tak jsem ji chtěl nainstalovat. Poučení pro příště: "nešťourat se v tom pokud to funguje" Aspoň mám o zábavu na dnešní večer postaráno. No a při nejhorším snad budou mít zálohy na webhostingu.

Nejbližší verze s dlouhodobou podporou bude mít označení 3.5. Nenutím Vás nenasazovat Joomla 3.0, je to Váš problém jestli ji nasadíte. Jen jsem Vám dal doporučení toho, jak to cítím já a co mám ověřeno.
Vždy můžete u nových verzí počítat s nějakou neočekávanou chybou, tak to je. A především u Joomla 3.0, která ani nebude dlouho podporována.
Joomla 2.5.x je v této době velmi stabilní a velmi dobře funkční. Podařilo se vychytat a opravit mnoho problémů. Myslím si, že Joomla 2.5 je zatím to nejlepší co vzniklo, i když ty zatracené upgrady, to bylo něco ;).
O Joomla 3.0 si zatím myslím jen to nejhorší, mě se ten systém nelíbí...ale to je můj názor, který nikomu necpu.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.