S češtinou nefunguje ukládání.

Radek
14. bře 2014 16:59 #114999
Dobrý den,
snad mi někdo poradí s obrovským problémem prosím :)
Po nainstalování poslední nebo i starší češtiny a jejím zapnutí nefunguje korektně tlačítlo Uložit nebo Uložit a zavřít. Po editaci čehokoliv a následnám Ukládání vykopne na přihlášení do adminu.
Pokud ponechám v adminu angl tak funguje vše, tak vypadá na problém s češtinou.

Joomla 2.5.1.9., šablona SJ Cars

Předem děkuji

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
14. bře 2014 19:04 #115002
Ten problém je v administraci, nebo v uživatelské části? V té uživatelské části jste zkoušel standardní šablonu?

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
14. bře 2014 19:19 #115008
Problém je jen v administraci a jen u cestiny.
U standartni sablony take, ale jaka je sablona ve frontu pouzita je pravdepodobne ted jedno.
Navic se zmeny ani neukladaji. Jakmile ale prepnu na naglictinu, je vse v poradku.
Nainstalil jsem desitky joomly, ale s takovou chybou jsem se nikdy nesetkal.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
14. bře 2014 19:28 - 14. bře 2014 19:30 #115009
Nenapadá mě jediný důvod proč by měl být problém s češtinou právě v tomto. Vyzkoušeno s J2.5.9 a poslední češtinou, vše funguje.

Nemáte na webu problém s vlastnictvím složek a souborů? Zkusil jste Joomlu aktualizovat (opravit, tedy nainstalovat kompletní instalačku jako kterékoli jiné rozšíření), případně opravit databázi (jak v Joomle tak phpMyAdmin)? Ve Správce jazyků vše řádně nastaveno?

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
14. bře 2014 22:41 #115012
Tak jsem zkusil preinstalit joomlu, ve spravcich jsem i zkusil stahnout cestinu z instalacniho balicku primo v adminu. Porad nic :(
0777 jsem dal na vsechny slozky, nic. zapl ladeni chyb, tam sice byla nejaka chyba v prekladu K2, naisntalil jsem cestinu, ale opet nic.
Na PHP jsem zapl zobrazeni chyb, ale nevyskoci nic. Prekerni situace, obesel bych se samozrejme bez cestiny v adminu, ale vypisuje spatne ceske znaky v polich kde je potreba cestina, např DIČ...

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
15. bře 2014 01:10 #115015

Radek_cz napsal: ale vypisuje spatne ceske znaky v polich kde je potreba cestina, např DIČ...

To je trochu zvláštní. I když máte Joomlu v angličtině, české znaky by měly být zobrazeny správně (a třeba i azbuka nebo čínština). Joomla je v UTF-8, zobrazí tedy úplně vše. Není problém spíš v databázi? Máte nastavený správně charset a collation?

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
17. bře 2014 11:38 #115040
collation connection utf8_general_ci
collation database utf8_general_ci
collation server utf8_general_ci

Vse utf8, jeste jsem ejdnou zkusil smaznout a nainstalovat, zkusil jsem i základní šablonu, stejný problém, když je zaplá čeština v adminu.
Pokud ponechám angl admin, tak nevypisuje české znaky, ale otazníky ve frontu i v adminu.
Ale myslím, že s databází nebude problém, s jinou instalací joomly funguje.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
17. bře 2014 11:50 #115041
ještě jedna zajímavost, pokud vytvořím menu tak nevypisuje správně češtinu. Pokud je puštěn VM kategorie a bere tedy kategorie z VM tak je čeština v pořádku. Takže si myslím, že je jen problém s češtinou v adminu.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Bong
17. bře 2014 12:09 #115042
Měl byste používat utf8_czech_ci, teprve pak bude vše pracovat správně. Ale to je jen poznámka, ne řešení vašeho problému.

Takže rozumím tomu dobře, že čeština je v překladu v pořádku, řádně se zobrazuje a problém je se zobrazením českých znaků uložených do databáze?

Jedná se o novou instalaci, nebo odněkud přesunutou? Co je to za hosting? Používáte jej běžně?
Zkusil jste vše (kompletně) smazat a provést čistou instalaci?

I'm sorry, my responses are limited...you must ask the right questions.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Radek
17. bře 2014 12:21 #115043
Je to testovací web, resp. prostor, kde jsem instaloval desítky jiných VM a bez problémů. Je u českého-hostingu a virtual server.
Asi bude celá instalace včetně šablony se nestandartně chovat, vypadá, že bude jednodušší na ni zapomenout :(

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.