Virtuemart2 CZ/SK

marvays
25. říj 2013 07:27 #112052
Ahoj. Mám problémy s jazyky. Vzal jsem funkční web v češtině, udělal kopii a předělal na slovenský. Myslím si, že jsem vše české odstranil a web je kompletně slovenský, jen při ukládání ve zboží mi to neustále hlásí hlášku:
vmError: Missing Flag ../media/mod_languages/images/.gif for language Czech (CZ).
www.dropbox.com/s/bv4abik707dppg2/cz.png

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od karel
25. říj 2013 07:50 - 25. říj 2013 07:53 #112053
Ahoj, údajně se tak stává při chybějícím nastaveni jazyka (obsahu) v samotné J.

Ve správci jazyků (J), ověřit existenci nastavení SK(CZ?) pro obsah... (případně vytvořit)

Znáte-li řešení, sdělte ho - pomůžete ostatním při řešení stejného problému, i případný "rádce" bude vědět, poradil-li správně nebo špatně.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Tomáš Štancl
28. lis 2013 21:29 #112990
A co dělat v případě, že čeština pro obsahy chybí a nejde přidat kvůli následující hlášce?

"Uložení se nepodařilo z důvodu následující chyby Jazyk obsahu s touto značkou jazyku již existuje."

Rozšíření > Správce jazyků > Obsah se zobrazuje pouze Angličtina, ale VM stále hlásí:

"vmError: Missing Flag ../media/mod_languages/images/cs.gif for language Czech (CZ).
Go to Extensions > Language Manager > Content, and check the parameter Image Prefix for this language."

Díky za radu.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od marvays
28. lis 2013 21:36 #112991
jestlis e pamatuju správně, prvotní problém je vtom, že to hledá tento obrázek, ale na ftp je po instalaci místo něj obrázek "cz.gif". Stačilo to jen přejmenovat na to, co vypisuje ta chyba a hotovo.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Cony
28. lis 2013 21:44 #112993
Nebo upravit nastavení pro ten jazyk - vlaječka je pro Českou Republiku - správný kód je cz ne cs - cs je kód jazyku.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Tomáš Štancl
28. lis 2013 22:10 #112996
Děkuji za rychlé odpovědi. Nakonec jsem to vyřešil aktivací jazyku v databázi, kde měl hodnotu -2. To stačilo změnit a hláška zmizela a vypadá to, že vše funguje.

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.

Odpověď od Tomáš Štancl
28. lis 2013 22:12 #112997
Obrázek jsem ale nahrál také :-)

Pro možnost přispívání do fóra je nutné: Přihlásit se nebo Vytvořit účet.