Přihlásit se

Joomla! 3.7

27. dub 2017 12:24 - 27. dub 2017 12:25 #131164
Odpověď od ferino
Tak pripojím moju malú skúsenosť s upgrade na J37:
väčšina webov bez problémov zvládla tento upgrade, a to boli rôzne verzie PHP (aj staré)
ale na jednom to skončilo takto, viď príloha.
Pritom upgrade skončil akože OK, bez akejkoľvek chyby, aj web v podstate beží, iba tie stringy chýbajú, v admin rozhraní mám English default, a keď sa pozriem na súbory do language foldra, vyzerá, že tam všetky sú, napriek tomu sa nezobrazujú.
Nechápem...
Přílohy:

27. dub 2017 21:04 #131170
Odpověď od Cony
A po zapnutí ladění chyb jazyku v globální konfiguraci to hlásí co?

27. dub 2017 23:16 #131176
Odpověď od Cony
Možná to s tím souvisí, možná ne (ale pro Bonga by to mohla být podstatná informace).

Joomla 3.7 již neumí pracovat s jazykovými soubory, které v překladech používají sekvenci "_QQ_" pro dvojité uvozovky. Tento způsob byl označen za zastaralý (deprecated) a není již nadále podporován.

28. dub 2017 08:44 #131188
Odpověď od Karel Neugebauer - itx.cz
Hojte,

Joomla 1.5 má problém i na PHP 5.3 (nebo 5.4) a vyšším, co si pamatuji, muselo se upravit něco v core souborech, nebylo to příliš těžké. Detaily ale hledejte na netu v angličtině, už je to dýl, a nepamatuju si je.

Joomla 3.7.0 nasazena na cca 30-50ti webech v různých kombinacích komponent a Virtuemartu, PHP od verze 5.6. po 7.1, nikde žádný trabl. Hosting hostime.cz

Hláška o PHP je v pořádku, ale taky je tam datum podpory do 31.12.2018, takže netřeba plašit. Pokud máte čistou Joomla, samozřejmě přepněte na 7.1, pokud tam máte komponenty, přepnout můžete, ale musíte si vše řádně otestovat. PHP 7.x je doporučeno z důvodu výrazně vyššího výkonu. Z pohledu bezpečnosti byste neměli pro novou Joomal používat starší verzi PHP než 5.6.x

[url] itx.cz [/url] - komplexní služby v IT a vše pro Joomla - šablony, komponenty, moduly, servis ... [url] hostime.cz [/url] - webhosting nejen s podporou Joomla

28. dub 2017 09:16 #131190
Odpověď od ferino

Cony napsal: Možná to s tím souvisí, možná ne (ale pro Bonga by to mohla být podstatná informace).

Joomla 3.7 již neumí pracovat s jazykovými soubory, které v překladech používají sekvenci "_QQ_" pro dvojité uvozovky. Tento způsob byl označen za zastaralý (deprecated) a není již nadále podporován.


asi to nebude celkom pravda, lebo som stiahol originál inštalačku J37, pozerám jazykové súbory a hneď v administrator/language/en-GB/en-GB.ini je tých sekvencií niekoľko.

Keď som zapol ladenie, tak tam mám kopec takýchto hlášok:
Code:
??PLG_DEBUG_LANG_NOT_LOADED?? : JROOT/administrator/language/en-GB/en-GB.ini
Pritom ten súbor je zhodný z originálom, aj som ho skúsil prepísať z originál inštalačky, ale výsledok rovnaký...

28. dub 2017 10:01 - 28. dub 2017 11:25 #131191
Odpověď od Bong

Cony napsal: Joomla 3.7 již neumí pracovat s jazykovými soubory, které v překladech používají sekvenci "_QQ_" pro dvojité uvozovky...

To je dobrá informace. Prozatím to funguje dál bez problémů, ale postupně překlady vyčistím.
S tímto je trochu problém, ono závisí i jak je napsaná komponenta. Někde se mohla, někde se nemohla a někdy dokonce musela sekvence "_QQ_" použít. Podobné to je i s použitím mezery v řetězci, někde lze použít, někde ne...

ferino napsal: ...bez akejkoľvek chyby, aj web v podstate beží, iba tie stringy chýbajú, v admin rozhraní mám English default,..

Zkuste zkontrolovat oprávnění a hlavně vlastnictví složek a souborů. Zkuste přepnout administraci i na jiné jazyky než je jen angličtina (globálně i pro vás jako uživatele). Frontend to nedělá?

I'm sorry, my responses are limited...you must ask the right questions.

Powered by Fórum