Joomla! 4 na obzoru

Vytisknout

Tento rok nás čeká relativně dost novinek. Pojďme se na ně podívat. Joomla 3.9 nabídne nástroj pro správu dat v rámci GDPR. Joomla 3.10 bude "mezičlánkem" mezi Joomla 3.x a Joomla 4.0 a přinese (omezenou) kompatibilitu API těchto dvou větví.

Joomla 4.0 bude novou hlavní verzí. Joomla 3.10 bude vydána společně s Joomla 4 a bude jako poslední minoritní větev - Joomla 3. Joomla 3.10 bude podporována po dobu 2 let. Tato doba poskytne dostatek času na přechod na Joomla 4 a aktualizaci rozšíření kompatibilních s novou verzí Joomly.

joomla 4 alpha3


Co Joomla! 4 nabídne nového?

Zde je souhrn toho nejzajímavějšího:

  • Nový Správce médií – přinese vícenásobný upload souborů pomocí funkce Drag and Drop („táhni a pusť“), nástroje pro správu souborů (editace, náhled, vlastnosti), nástroj pro editaci obrázků (oříznutí, změna velikosti, otočení)
  • Přepracovaný a jednodušší nový Instalátor Joomly – instalace ve 3 krocích, přepracovaná ukázková data
  • Masivní vyčištění kódu – odstranění zastaralých funkcí z Joomla 3.x (přes 1000 zastaralých tříd a funkcí) a přidání podpory jmenných prostorů PHP
  • Jednodušší upgrade na verzi 4 – ověření stávající kompatibility (včetně nainstalovaných rozšíření) a požadavků v Joomla 3.10 potřebných pro provoz Joomla 4 pomocí skriptu kompabitility
  • Nové uživatelské rozhraní pro administraci (backend) a veřejnou část (frontend), založené na Bootstrap 4
  • Administrační šablona s podporou WCAG 2.0 (úroveň AA)
  • Sloučení Joomla Frameworku s CMS
  • Nové funkce zabezpečení jako například podpora předpřipravených SQL příkazů
  • Přepracovaný správce událostí
  • Nový servisní kontejner pro globální závislosti
  • Nové možnosti napojení UI na libovolný Framework
  • Rychlejší načítání stránek skrz redukci počtu skriptů
  • Vylepšené SEO
  • Nová přihlašovací stránka do administrace – s možností přizpůsobení (nastavení vlastního loga, nastavení vlastního pozadí)
  • Přepracovaná stránka pro administraci komponent (Hledání, Bannery..)
  • Přepracované nastavení - nabídne všechny možnosti konfigurace, instalace, přístupu, správy na jedné stránce.
  • Administrace připravená na mobilní zařízení
  • Finální vylepšení routování
  • Hypermedia API (webové služby)
  • Oddělení jQuery od jádra Joomly (přesunutí mimo jádro)
  • A další…

   Video: Joomla 4.0 Alpha 3 v češtině - Ukázka


Plán vývoje

4.0.0 Alpha

Joomla 4.0 Alpha 1 Released for Testing

17. listopadu 2017

4.0.0 Alpha 2

Breaking News: Joomla 4.0 Alpha 2 is here! - It is for testing ONLY

19. listopadu 2017

4.0.0 Alpha 3

Joomla! 4 is on the horizon …

12. května 2018

Beta

 

3. čtvrtletí 2018

RC

 

Konec 3. čtvrtletí 2018

Stable

 

4. čtvrtletí


Systémové požadavky Joomla 4 byly aktualizovány na:

  • PHP 7
  • MySQL 5.5.3
  • PostgreSQL 9.2
  • Podpora SQL Serveru bude zrušena.

Externí knihovny

Následující změny byly provedeny u externích knihoven, které Joomla! jsou součástí balíčků CMS.

  • Aktualizace PHPMailer 5.2 na verzi 6.0
  • Knihovna SimplePie nebude v Joomla! 4.0 zahrnuta
  • jQuery 3 součástí Joomla! 4.0
  • Bootstrap 4 součástí Joomla! 4.0 (Bootstrap 2.3.2 bude odstraněn)

Šablony

Všechny šablony, které jsou součástí Joomla! 3 – jmenovitě pro administraci: ISIS, Hathor, pro veřejnou část: protostar, Beeze nebudou nadále ve verzi 4 podporovány.

V Joomla 4.0 budou dostupné 2 šablony:

  • pro administraci – Atum
  • pro veřejnou část – Cassiopeia.

Z důvodu aktualizace knihovny Bootstrap na verzi 4 je nutné provést migraci všech rozšíření (využívají-li Bootstrap předchozí verze).


Jak upgradovat na Joomla 4.0

Pro upgrade na Joomlu 4, bude třeba mít poslední verzi větve Joomly 3.x.

V závislosti na nainstalovaných rozšířeních nebude možné aktualizovat web z verze 3.x na 4.0, dokud nebude splněna komptabilita všech vašich rozšíření s verzí 4.0

Ve verzi 3.10 bude možné zobrazit informaci o kompatibilitě rozšíření s Joomla 4 pomocí skriptu testujícího kompatibilitu rozšíření.


Srovnání: verze Joomla 3.x a Joomla 4.0

Verze 3.x

Verze 4.0

Bootstrap 2

Bootstrap 4

LESS

SASS

Responzivní

Mobile first responzivní design

 

Jednodušší instalační proces

2 šablony pro veřejnou část (frontend)

1 šablona pro veřejnou část

2 šablony pro administraci (backend)

1 šablona pro administraci

MooTools

(MooTools odstraněno)

Minimální verze PHP: 5.3

Minimální verze PHP: 7

Administrace: horizontální menu

Administrace: vertikální menu

Zastaralé funkce

Nejnovější funkce (Bootstrap 4, jQuery 3, PHPMailer 6.0.)

 

Čistý a optimalizovaný kód (vylepšená MVC vrstva, ortogonální struktura komponent, UI používající nejnovější funkce a technologie)

 

Více bezpečnostních funkcí


Poznámky

  • Rozšíření pro verzi 3.x nebudou kompatibilní s verzí 4.0
  • Běh pouze na PHP 7 a vyšší

Joomla 3.9

  • Nástroj com_privacy - funkce ochrany a správy osobních údajů (připravení na GDPR)

Joomla 3.10

  • Joomla! 3.10 bude verze obsahující zpětnou (omezenou) kompatibilicu změn API z vývojové větve 4.0 a umožní jednodušší přechod na majoritní verzi Joomla 4.0.
  • Joomla verze 3.10 a 4.0 budou uvolněny současně
  • Joomla 3.10 bude podporována po dobu 2 let

Odkazy

Diskutujte o tomto článku ve fóru (1 odpovědí).

Poslední novinky z fóra

Další témata »

Joomlaportál si prohlíží...

Právě přítomno: 450 hostů a jeden člen

Joomla!® je registrovaná ochranná známka společnosti Open Source Matters. © 2004-2012 JoomlaPortal.cz - provozováno Testudo corp. s.r.o. Powered by Twitter Bootstrap Framework. Design by Linelab.org

Jakékoliv užití obsahu včetně převzetí, šíření či dalšího zpřístupňování článků, diskuzních příspěvků a dalších textů je povolenou jen se souhlasem provozovatele.

Domů | Licence | O komunitě Joomla | Kontakty | Hledat na webu